HELP ! Could not connect to UiPath Robot Service. Make sure the service is started!

My Version is 2019.6.0, how can I solve this ? the problem is I unable to amend run-service.msc-uipath robot as im using my company laptop. any other way to solve this ? really appreciate your kind assistance.

Hey @ajimasyraf95,

Welcome to the UiPath Community !!.

Please check the uipath robot service status.

type services.msc in the run prompt and find UiPath Robot Service.Restart the service and try again.

Hi @ajimasyraf95,

I met the same issue before and this may caused by some reasons. My reason is the UiPath Robot Service issue.

You can also try to check the windows service of your laptop. Find the ‘UiPath Robot Service’ and restart it to see whether it can be solved or not?

Hi @amarasto and @aisling.bai
I already done the restart thing , but still it show the same error. There’s any other way to solve this ?
really appreciated your kind reply. :smiley:

Hi @ajimasyraf95,

Please find the Chinese UIPath team’s answer as below (They sent to me, confused with the third way):

Three Possibilities:

  1. UiPath Robot can’t connect to Orchestrator to get a license. Make sure Orchestratror is connected to the Robot network and that the remaining number of licenses is sufficient.

  2. Robot Service service exception. It is recommended to find UiPath Robot Service in Windows Service Manager

  3. License exception, you can try to provide online and offline ways of reactivation, reactivation after successful reactivation

Thanks,
Aisling

1 Like

Hey @ajimasyraf95,

Please stop the service and start it again from the task manager.Give it a try.

1 Like

Hi @amarasto and @aisling.bai

thank you very much, its work. I can use my uipath again.

really appreciated your support and assistances.

Hey @ajimasyraf95,

Please mark the appropriate solution and let other community members know.