Hardware events selector keep throwing error


I’m using a strict selector for my activities. I’m using a 4 second delay before click and using hardware events. Sometime it clicks, sometime it won’t click so I have to click manually and the robot proceeds everything afterwards, and sometimes it’s clicking responsively without any error. Any explanation for this? Thanks !

Hey @Rhys18,

There are two ways you can get rid of this issue.

  1. Either you can use the element exist activity to check whether that element exists or not the default timeout for that activity is 30sec, if that output is true you can perform your click else you can do as per your requirement in the else block.
  2. You can use On Element Appear activity and capture that element once that element is appear the click would get performed.


Hello @Rhys18

Can you comfirm whethe the application has properly loaded while clicking?

Use element existss and if present then use click activity.


Ok I will try this first. Will provide you the update for the next few days

It’s internal web based application. I can’t share it here because it’s company asset, the click is not working only at 1 part only but the rest are working.

You dont need to share the ss here then. But add an element that exists and waits for it to load completely. Then use click activity. Are you using the modern click activity, if yes, in it automatically it will get tag to an anchor.


Hello @Rhys18 ,

Things you can try to overcome this issue :

  1. Try if the application allows simulate Click (if allowed, please use it)
  2. Try giving default timeout / delay (4 sec looks very less, the required element in the application may not be loaded in 4 sec)
  3. If the above settings didn’t work go for element exists (with default timeout) to make sure the element is exists and it’s loaded.


Hi, sorry for the very late update.

So I tried the simulate click and it’s not even clicking at all, just moving my cursor to the element that I want to click. Using hardware event sometimes it works and error, default more than 5 seconds isn’t allowed by my co-worker because it’s taking too long. Last option I should try is using get attribute activity to validate.

If it’s not working too, can I just update the excel input data by deleting row 1 by 1 after inputting the data?


Using hardware event sometimes it works and error

Can you please share the selector for this.

Currently the robot is in used because it’s in server. What information you wanna know? If you asking about selector, I’m using strict selector and not fuzzy selector, with image checked.

Thanks for this @rohith.prabhu I really appreciate the help ! This one is the solution that I tried and so far I receive no error. Thank you very much !

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.