Gsuite - google drive - write range into google sheet

Hello! Im struggling to write range from my csv table to a datasheet in google. I keep getting an error:
“Write Range: Invalid Range specified.
Parameter name: StartingCell”
Tried using cell “A1”, null and a range “A1:D3000” and many others.
Couldn’t find any useful help in the documentation of this api.

1 Like

Hi @nahuel_casagrande,

Please test with a table with only one row and only one column with a simple value, like 123.

Have tried to use “” in the StartingCell field?

Hi @nahuel_casagrande,

If i’m not wrong, the “StartingCell” cell property refers only to the Starting cell, which based on your print, is “A1”.

So, try to put only “A1”, and the activity should handle the rest.

Tks.

Already tried with A1 and it didn’t work. maybe is because im getting a full table with multiple rows. can’t find documentation to work with tables.

Does not allow to use empty starting cell, it gives a parameter error when running.
I’m going to try with a simple value, but is there any documentation to work with tables with multiple rows and columns?

Hi @nahuel_casagrande,

I know the following documentation:



About the test with only one row and column with a simple value, let me know if it works. I want to understand if is something related to the content of your datatable, even that the exception says that is something related to an invalid range.

I tested here and my automation was able to write a table with multiple rows and columns, informing A1 as StartingCell.

I would also like to know if the Delete Range activity works before the Write Range is executed? Is the content deleted?

Thanks for the documentation, i’ll check and see if i get any info on how to manage tables.
Did the test as you required and it works fine with one column, tried with one column, one row and increase it to one column to 2000 rows and also worked. I guess my problem is with my next two columns as it has a timestamp format.
an other test i did is with two columns with similar format and it is pasted but all in the same column.
image
The delete range works fine.

Thanks for your help :smiley:

My suggestion is for you to take a look at your datatable before you insert it, maybe something is wrong when you are reading your CSV…

Hi @nahuel_casagrande

Glad it helped you!

So, it’s related to the content. Your implementation is working fine :slight_smile:

Now you just need to analyze and identify what is causing the error.

Kindly mark the answer that helped you as solution

Thanks

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.