Git Init is disabled on Team page

Dear All,

I am using UiPath community 2019.7 version. I want to set up version control using GIT.
When i clone repository using the devops repository, a .git folder is created in my local directory but HEAD file is not created.

Issue: I want to add a project to GIT but the problem is “GIT Init” is disabled. Could you please help me to enable it?

Check this post @kavita

Thanks for the reply but I had read this post. This does not work.

1 Like

Hi @kavita

Check this

GIT integration

Thanks
Ashwin.S

@AshwinS2

I have read this thread. This does not address this issue.

@ovi, @Pablito
Dear Ovi/Pablito,

Please help me regarding this issue. This is urgent!

Hi @kavita,
Can you describe a little more this case. If you could do step-by-step with screens and where the problem exactly occurs it could help with finding out the solution :slight_smile:

Sure @Pablito. PFB the steps followed:

  1. Launched UiPath Studio

  2. clicked on “Team” and then “clone repository”

  3. Clone repository dialog box opens. I have entered devops repository URL and check out directory(empty folder), username and password and then clicked on “Open”

  4. I get below message box

  5. A .git folder is created in the checkout directory

  6. Next, I open a project in studio. main file opened

  7. Now , when I go back to “Team” page, all the options of Git are disabled

Please help me!

Just my thoughts based on this instruction:


Can you check the same using different folder (not UiPath)? Just make new folder on desktop like in example from documentation.

I tried changing directory to the one on desktop, but there was no change.

However, I restarted studio and this time"clone repository" and “Disconnect” are enabled, but “copy to Git” and “Git init” are still disabled.

Do you have any project opened? As documentation says:
image

Yes, as given in point 6, main.xaml is opened

Hi @kavita

As mentioned by @Pablito, could you maybe try with an empty project? The option should be active then.

I think the core of the issue is that your existing project is not being copied over successfully (and the one that is opened is already ‘considered’ as part of the source control folder).

Please try it with an new project in completely different directory and see if Copy to GIT option is active.

1 Like

@loginerror
As per recommendation i have tried this:
I have restarted the studio, created new project in a new blank directory(other than uipath folder), but this time also all the four git options are disabled. Please help!

Please help me regarding this issue

Do you have GIT installed in your machine @kavita?

No harish. I am doing with Azure devops repository for GIT

Let me give a gist @kavita

If a team have a SVN repo accessible for all the members and the SVN server is located in a remote, then everyone have to install SVN to clone or checkout the code. Similarly, for connecting to any GIT, we need to have GIT Bash installed in your machine. This is what I assume :slight_smile:

But , please give a try to clone the repo using command prompt or GIT Bash.

1 Like

Hi All ,Same problem exactly happened to me ,i tried changing directory from uipath to desktop,clone repository and disconnect options are activated, i clicked disconnect,then “git init” and “copy to git” options are enabled. I tried same things for other projects on the desktop. It is disabled for all projects that time,changing the project location is not working now. I am doomed with this problem,can you please help???