GIT Credential Error - Request Failed with status Code 503


Wasn’t able to find a solution to this - wondered if I could get some help:

Environment: working in a clients citrix environment.
Studio: Installed on machine - not locally for a user.
Version: 2021.10.3

I originally tried to ‘GIT Init’ a repo in UiPath Studio using my Username+Password for GitLab. My account is setup with 2FA, so this gave an error - i only realised after the fact that i need to configure a token and use that. (i can connect and use git functionality fine on my local machine with this). In this citrix machine, i get an error when i attempt to change credentials in the ‘manage remotes’ screen, and the credentials are not in my credential manager, where they usually should be.

Im not sure if this is a feature of the way uipath in installed / or being in a citrix environment, but the credentials aren’t available in my credential manager to delete.

Error Message: request failed with status code: 503

request failed with status code: 503

Error: LibGit2Sharp.LibGit2SharpException: request failed with status code: 503
   at LibGit2Sharp.Core.Ensure.HandleError(Int32 result)
   at LibGit2Sharp.Core.Proxy.git_remote_fetch(RemoteHandle remote, IEnumerable`1 refSpecs, GitFetchOptions fetchOptions, String logMessage)
   at LibGit2Sharp.Commands.Fetch(Repository repository, String remote, IEnumerable`1 refspecs, FetchOptions options, String logMessage)
   at UiPath.Studio.Plugin.Git.Wrappers.CommandsWrapper.Fetch(IRepository repository, String remote, IEnumerable`1 refSpecs, FetchOptions options, String logMessage)
   at UiPath.Studio.Plugin.Git.Services.FetchService.<>c__DisplayClass4_0.<AttemptFetch>b__2()
   at UiPath.Studio.Plugin.Git.Desktop.Services.UiAuthenticationSession.Execute[T](ExecuteArgs`1 args)
   at UiPath.Studio.Plugin.Git.Services.FetchService.AttemptFetch(IRepository repository, Boolean disableCredentialsManager)
   at UiPath.Studio.Plugin.Git.Desktop.Services.ChangeCredentialsUiService.<>c__DisplayClass11_0.<ChangeCredentialsExecute>b__0(IRepository repository)
   at UiPath.Studio.Plugin.Git.Services.GitSession.ThreadSafeExecute[TResult](Func`2 action, Func`1 repoFactory)
   at UiPath.Studio.Plugin.Git.Services.GitSession.<>c__DisplayClass16_0`1.<ExecuteAsync>b__0(CancellationToken _)
   at UiPath.Shared.ProducerConsumerPair.<>c__DisplayClass18_0`1.<StartNew>b__0()
   at System.Threading.Tasks.Task`1.InnerInvoke()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
--- End of stack trace from previous location ---
   at System.Threading.Tasks.Task.ExecuteWithThreadLocal(Task& currentTaskSlot, Thread threadPoolThread)
--- End of stack trace from previous location ---
   at UiPath.Studio.Plugin.Git.Services.GitSession.ExecuteAsync[TResult](Func`2 action)
   at UiPath.Studio.Plugin.Git.Desktop.Services.ChangeCredentialsUiService.ChangeCredentialsExecute(String name)
   at UiPath.Studio.Plugin.Git.Desktop.Services.ChangeCredentialsUiService.ChangeCredentialsExecute(RemoteViewModel remote)
   at UiPath.Studio.Plugin.Git.Desktop.Services.ChangeCredentialsUiService.<.ctor>b__5_0(RemoteViewModel model)
   at UiPath.Studio.App.Desktop.MVVM.Commands.TaskCommand`3.Execute(TExecuteParameter parameter, Boolean ignoreCanExecuteCheck)
   at System.Threading.Tasks.Task.<>c.<ThrowAsync>b__140_0(Object state)
   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler), HResult -2146233088

Hopefully it could be as simple as i need to look in a different place :sweat_smile: Thanks!


Go through this docs…



Thanks for your idea - i couldn’t see anything in that doc which could give me a resolution (i tried checking a few more places based off that doc with no luck), i appreciate this is such a niche problem.


To Close this one off - since there was no resolution.

I disregarded the GIT functionality in UiPath and used GIT BASH via SSH as a workaround / cleaner approach to managing my code. :man_shrugging:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.