Getting this message even after having admin access after installing UiPath 2020.4 Enterprise.You do not have permission to update Orchestrator Settings. Please contact your company administrator for help

I have the admin access to my PC and I have installed the UiPath 2020.4 version. But when I try to configure the orchestrator I am getting a message “You do not have permission to update Orchestrator Settings. Please contact your company administrator for help”

Hi @suraj3501

Please open computer management and go to local users and groups select groups and check your domain name is available in administrator group.
to get domain name run cmd command and type whoami

Please mark as solution if found useful :slight_smile:

1 Like

I’m testing 20.4.1 and seeing the same message as well. I’m added in the admin group as unknownay suggested. We have Thycotic as our privilege access management so not sure if that’s relevant as well. On the same machine and same user, when I install legacy robot (Uipath Robot) instead, I have no issues with access to Orchestrator Settings. Once I try to reinstall Assistant, it gives the same error.

I found a workaround to use the command prompt instead… and it worked… at least configured the orchestrator setting.
From the Command Line

  1. Save the machine key generated in Orchestrator to the Clipboard or a file.
  2. Open Command Prompt.
  3. Go to the directory where your UiPath Robot is installed (by default C:\Program Files (x86)\UiPath\Studio). For example: cd C:\Program Files (x86)\UiPath\Studio.
  4. Use the --connect, -url and -key command line arguments in conjunction with the Orchestrator URL and machine key. For example: UiRobot.exe --connect -url https://demo.uipath.com/ -key ba1e4809-2f64-4965-bae2-efda62d20164. UiPath Robot is now connected to Orchestrator. In a High-Density environment, the Robot corresponding to each user is connected to Orchestrator.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.