Robot tray orchestrator settings - Administration rights

Scenario: I Work in a large organization and intend to deploy (using Orchestrator) attended scripts to multiple users. We have packaged UiPath Robot (robot tray) for automatic distribution and set up so that a normal user may apply for access and then have the Robot installed.

However it seems that when a user gets the Robot installed, admin rights are required to update Orchestrator settings with URL and Machine Key. A normal user will not be granted admin rights. I would like to avoid the task of a priviledged user remotely taking over a normal user’s screen and updating Orchestrator settings after each installation. Is there a solution to this? E.g. a setting that removes the admin rights requirement or to “pre-populate” the values during distribution/installation?

Thanks!

Hi @andan,
Welcome to the Community!
If you have administrative privileges you can try to remotely setup robot on user side using power shell (remote scripting needs to be enabled through GPO). List of command you have here:

1 Like

Hi Pablito,
thank you for your answer. I’ve tried to connect manually from cmd with the command --connect -url [orch url] -key [machinekey] but get an error message ‘A task was canceled’. That’s the same error message I get when attempting to enter the values manually through the robot tray - orchestrator settings interface. Do you have any idea what the problem is?
Thanks in advance
/Anders

Maybe you are typing wrong URL? Please look at the forum banner or here:

The orchestrator we connect to is v2018.4.6 so I don’t think that’s it. I suspect a firewall issue; do you know which ports are used when connecting to orch?

I think you should create ticket for this case here:

It works now, we had to open traffic through the firewall on port 443 to the orchestrator host. Thanks for your help anyway.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.