Getting "SEHException" Error with 'Open Browser' activity


#1

Hi,

Can anybody help?
Open browser activity is giving this error;

image

I have searched the forum and a possible cause suggested was that the Robot version was old.
I have checked and Studio and Robot are both version 2018.1.3.
I tried killing the Robot in task manager and re-starting but still didn’t work.

Also, it works fine if I open an IE browser but not Chrome.
I have always used Chrome and it always worked before so I can’t understand why it is not working now.

Any ideas?

This is the ‘Open Browser’ activity;

Thanks,
Dave


#2

Hi Dave,

Do you have the extension install for Chrome? If yes, can you create another project and test is separately to see if is working?

Thanks,
Ninett


#3

Thanks Ninnett,

Yes, the extension for Chrome is installed.
I closed studio and re-opened, then created a new project. The ‘Attach Browser’ activity worked there so I closed that and re-opened my original project.

Now, the ‘Attach Browser’ works but the ‘Click’ activity won’t recognise the buttons - keeps saying “UI Element not valid”. I have done the ‘Click’ activity many times before with Chrome and it worked no problem.

If I try the same thing in IE, it works fine.

Something strange has happened to Chrome or UiPath and I have no idea what.

Thanks again,
Dave,


#4

Hi Dave,

It the page that you automate is not necessary to be open with Chrome, I recommend you to use IE. Why? Because the selectors for IE are better than all of this in Chrome. Chrome comes with many updates all the time and is not so stable compare with IE.

Thanks,
Ninett


#5

Hi Ninett,

I was hoping not to have to go through my project and change all activities using Chrome to use IE but from your advice it would be the best solution.

Will do it now and always use IE in future.

Thanks for your help, :smile:


#6

great! thanks! :slight_smile:
I will recommend you in the future all the time to use IE if this one is supported by your web browser.

Thanks,
Ninett