Getting exception on Send mail :The specified object was not found in the store

The automated bot was running without any issues from long but now I am facing the issue in ‘send mail’ activity in microsoft office 365 scope.

(i.e) Send Mail: Code: ErrorItemNotFound Message: The specified object was not found in the store. ClientRequestId:

Can anyone help me out from this issue. Thanks!!

Hello Jamuna,

Please update Microsoft office package to new version and try it.

Thank you,

I had similar issues and I had to downgraded version of this activity to 1.14.1

We were receiving the same error on 1.14.1. You need to update to the highest supported by your studio version to fix it. Seems like an update on the MS side recently. We had a package that hasn’t been touched in 6 months start receiving that error this week.

It does not work for us on any version other than 1.14.1
Maybe it depends on the configuration in Azure.
I’ll have to look into it… when I find the time of course xD

If it helps we’re on studio 23.4 and using ApplicationID/Secret for the authentication type in the Office365ApplicationScope. MS did deprecate Basic Auth so that could be your issue when going up a version (if that’s what you’re using)- Activities - Release notes (

I’m having the same issue as well… it suddently appeared… For me issue is with adding multiple attachments to sendmail. single attchement works fine.
UiPath.MicrosoftOffice365.Activities 1.14.1 is used

Soluction worked for me: Update Microsoft office package to 2.2.3 and excel package to latest one.
This is how my issue got resolve.


Hi @jamuna.t

Ensure that any libraries or packages your bot depends on are up-to-date. Sometimes, issues can be resolved by updating to the latest version of the relevant libraries.

I can confirm that the package update to 2.2.3 works properly.
However we need remember that we have to fill field account which is optional, but without that we’ll get bad request error.


Thanks @pikorpa . I have upgraded package to the latest 2.4.3 and supplied the Account field and is working fine for me. without the account field it was giving bad request error.


Soem of you are having the same problem using Graph Office365 application?

How did you solve it?



We are having some problem with mails with 2 or more attachments.

Some key point?


1 Like

Update the Microsoft o365 package to 2.2.7 and it is resolved the problem


What Studio version do you have? Thanks

studio version 2023.10.0 but it did not resolve the problem fully.
Try to upgrade the studio 2023.10.2