Getting error while trying to send mail

When i try to send mail… using uipath. i am getting the below exception

Kindly help me on that

1 Like

Hi @Kavin,

What is the smtp server you are using and check the port name once…

If you are using gmail smtp, check this post, it will help you

@Kavin

Are you getting this exception Everytime ?

It’s not UIpath exception and problem with your SMTP connection and please check once.

i tried but still getting the same error
port : 465
server : smtp.gmail.com

also enabled less secure app

yes
how should i resolve it?

@Kavin

Please check below thread and may be it will help to you.

Facing problem while sending SMTP Mail

Buddy @Kavin

Connect on port 587 if you’re using TLS and kindly make sure that it allows less secure apps to access your account.
https://support.google.com/accounts/answer/6010255?hl=en

Cheers

Is that working buddy

Cheerrs

No… getting same error

1 Like

No worries buddy @Kavin here is your solution hope this would work

https://www.smartftp.com/support/kb/a-connection-attempt-failed-because-the-connected-party-did-not-properly-respond-after-a-period-of-time-or-established-connection-failed-because-connected-host-has-failed-to-respond-f2707.html

Cheers

Hi everyone,

I tried everything , port 587 , 465 , enabled less secure app. but still getting the same error.

Kindly help me to solve this issue

Buddy @Kavin

  1. Try to send with send outlook mail activity if outlook is installed in your system or try with send exchange mail activity , same you will be in need of server details and credentials, while if it is outlook very better no need of those details…only receiver details
    That would work, may be the server that you are in is not taking smtp ports no worries, lets try with other two options buddy

Cheers

hey @Kavin,

Try if either of two or both of the following get your problem solved:

  1. Enable IMAP and POP3 under “Forwarding and POP/IMAP” tab of “settings” of your gmail.
  2. Try disabling your firewall temporarily.

Let us kno if it helps.

Regards

Did that work for you buddy… @Kavin

It was not worked

Not tried using outlook, let me try and come back to you

yea i tried in outlook, but both the outlook id should be configured in the system then only it was sending the mail.

for gmail any other possibilities? as i am using company system i can’t disable firewall

1 Like

No worries buddy @Kavin
if your system is not configured with outlook you can use other send mail activities like this
Send SMTP mail activity and Send Exchange mail activity where you can mention the username and password with server and port of your account buddy
Even gmail can be configured with the above two activities buddy
Thats all buddy @Kavin
Kindly try this and let know buddy whether this works or not buddy
Cheer s

1 Like

Did that work buddy @Kavin