Getting "Error detecting project version" when project is run on machine with a minimal UiPath Robot installation

I have created a process. It works when I run it. I published that project, run it in the UiPath Robot and it works.

Now I installed UiPath Robot via the command line minimal background install on another machine. Start UiPath Robot and enter Orchestrator Credentials. Click on the same Project to run it. But here I get instead:
image

Why I get the “Error detecting project version”. What can I do?

I already tried the hack to change the schemaversion from 4.0. to 3.2. But after publishing into a new version the project.json file is renewed. So this is no solution for me.

Your process was created/edited and published with a newer Studio version (=> 19.7). Older robots cannot use this project.

You have two options :

  1. Delete the project.json and open the Main.xaml with Studio 19.4.4 (Or an older Studio than your robots). [write down your dependencies to make sure you add them]
  2. Start a new project (an older Studio than your robots) add your dependencies and using import workflow add the xamls from the >19.7 folder.

Similar issues:

I will try your ideas next monday. But that look like hard workaround. Isn’t there something out-of-the-box out there? I can’t believe that I’m the first one that want to let run thr Robot on multiple devices without a Studio install. Maybe I think in a wrong way? Do you have another hint for me? Thanks.

You are trying to run using an old robot a process designed with a new studio. Unfortunately, to add new features in Studio, changes are needed on project.json structure.

So the only way is to use an older Studio Version. Ohh my gosh. That’s not a solution for me. Neither to install Studio on the other machines. Is there really no proper workaround out there with a minimal install?

I cannot understand that the usual way of everyone is that the Studio is installed on all machines. Is that really the recommended way?

Try to get the Robot which has the same version number with the studio you use installed on your machine if you purchased a Robot license.

Hi @kwoxer

Please see the article here first:

We offer backward compatibility (you can run your older projects on new versions), but not forward compatibility (you cannot run newer projects on the older version because the older Robot does not understand the new features that were added in new version).

In short though - Studio and Robot should be on the same version and the issue will never manifest itself.
The easiest way to ensure you are good to go would be to install Studio from the Enterprise installer (current latest version 2019.4.4).

With this installer, neither Robot nor Studio will auto-update and you get to choose which component to install on which machine (either Studio+Robot or just Robot).

Also, the free Community Edition comes with an installer that will always install Studio + Robot and will always auto-update to the latest version. This is why you should not use the Community Installer to develop robots that should be run on the Enterprise edition. It introduces new features every month and these might not be compatible with older versions.

The auto-update is one of the only significant differences between the CE and Enterprise version and can be consider, if you will, a restriction of the otherwise free version of our software :slight_smile:
(the other one would be the type of robot it installs: https://docs.uipath.com/robot/docs/about-robot-deployment-types).

Well which version the current Enterprise version comes with? I think it’s Robot2019… isn’t it?

If so the docs are not correct https://docs.uipath.com/robot/docs/about-backward-and-forward-compatibility

Anyway I just install Studio now anywhere and I’m good. In my mind not a proper way but it’s fine for me to know that my way is impossible.

1 Like

Well which version the current Enterprise version comes with? I think it’s Robot2019… isn’t it?

Every installer will always come with the same version of Studio + Robot. Thus, Enterprise MSI installer 2019.4.4 comes with the robot 2019.4.4.


I have re-read your original post to make sure we’re on the same page. Could you confirm if this scenario fits your case:

  • You installed Studio+Robot using the community .exe installer on the machine that was used to create the project (this would be the latest 2019.9.2 version)
  • You then installed just the Robot using the MSI installer on the machine that was used to try to run the process (this would have to be the 2019.4.4 version, as community installer does not offer the option to choose specific components to be installed).

In such case, the process developed in 2019.9.2 will not run on 2019.4.4 robot due to changes in the schema version that happened between 2019.6 and 2019.7 (if I recall correctly).

The fact that this helped: “Anyway I just install Studio now anywhere and I’m good.” tells me that you have now used the community .exe installer on both machines, which makes them match and working correctly.


Lastly, one more way to receive the new (preview) versions of the Enterprise MSI installer that match the Community Edition, would be via our Insider program:

I hope it makes things clear, at last :slight_smile:

1 Like

Thanks, it’s fine. I just saw now that I read Studio instead of Orch.
Orch v19.FT.x Orch v18.4.x Orch v18.3.x

Maybe you could create a docs page with a Matrix of Studio and Robot. I know it’s obsolete because Robot needs to be equal or higher. But this would make it way clearer anyway.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.