Where I can find the UiPath Log File and how to solve the "Error detection project version" issue?

I got the “error detection project version” message when I ran the robot on VM machine. I tried to look at the log file on the VM machine, but could not find it.

On my PC which has community edition studio installed and the Logs is located at c:\Users\user name\AppData\Local\UiPath. But on the VM Windows server which has an unattended licensed Robot (version 2019.4.4) installed only. There is no UiPath folder at c:\Users\user name\AppData\Local\ . Where is the log file located at this VM?

I used community edition studio which has version 2019.7.0 to develop the process.
We bought an unattended Robot license (version is 2019.4.4) and installed it on a VM machine without either orchestrator or studio installed.
We don’t want to install the community edition studio on production environment. How can we keep both studio and licensed Robot synchronized all the time? Is there a way I can open my project in version 2019.4.4 by using community edition studio?

Thanks.

Hi!

On enterprise installations the installation folder is C:\Program Files (x86)\UiPath there you’ll find the Log folder.

Regarding project version, the problem is that in 2019.7 version the project.json content changed, and so the schema version of the file was updated (from 3.2 to 4.0 I think)

What you could try to do is:
Do not forget to back up before THIS COULD BREAK THINGS

  1. If you had previously published the project from a version before 2019.7, get that project.json file and override the one from you development environment.
  2. Manually enter the 2019.6 version from C:\Users\nicoerlichman\AppData\Local\UiPath\app-19.6.0.... You should have a 2019.6 folder if you didn’t do a fresh 2019.7 install.
  3. The publish, this will generate a package with a readable project version. Keep in mind that if you want to run processes in versions older than 2019.7, you must publish the package from a Studio version 2019.6 or lower.

Thanks for reply.
But I only have 2019.6 on my PC and I think I could not go back the 2019.4.4.

So I tried to install community edition ( the one I used to install on my PC) in our dev environment for testing, both installation and activation are fine. Then I published the project to dev server, but got error after I clicked the start button from Robot Tray(Please see attachment for details), then Robot tray always has “Error connecting to Robot services”.

I used the same email to activate the CE on both machine.

Any suggestion to solve this issue?

Thank you very much for your help

Robot Error.zip (1.0 KB)

Hi!

What you can do is download the the enterprise installer (2019.4) from the resource center of your cloud platform, which can also be licensed as community version.
Btw thanks @loginerror for the information

Then you can do the first and last points from my last reply.

Hope you can solve your problem now!

1 Like

Take a try of editing the project.json file. Edit the “schemaVesion” to lower version like “3.8” or “3.2”, and “StudioVersion” to “2019.4”. I have same exception like this when I run the project on 2019.06 which from 2019.07. And it work after I change the schemaversion to 3.8 and studioversion to 2019.6.