Get Transaction Items Activity does not get the transaction from Orchestrator Queue

Hii everyone ,

I am trying to get all my transactions from one of my Queue avaliable at the Orchestrator but at the studio , get Transaction Item Activity does not get any data even though there are couple of transactions avaliable in the Orchestrator Queue.

Look at the snipets below.

Thank You !

Hi @Rusira_Liyanage

Hard to tell by the provided screenshot.

Can you provide the Orchestrator screenshot?

There we go :slight_smile:

Thank You !

Hi @Rusira_Liyanage

I could see the transaction status is in “Successful”.

Get transaction item will pick only the status is in “In Progress”.

Hope this is what you are expecting.

Feel free to reach us at any time if you have doubts. Thanks.

Happy Automation

Hii @vignesh.ks

Thank you for your clarification but I am not sure about your comments. The problem is actually like I can’t get the Queue items from the Orchestrater as I prerior mentioned.

Hi @Rusira_Liyanage

Since you have many folders, do you already tried specify of which folder you want the queue items?

Hii @alexandretperez

Thank you for your recomandation. I just tried it out but I am getting an error as you can see in the picture below.

Thank You !

Hi @Rusira_Liyanage

You are right, it will not work because the fully qualified name is not just “My Workspace”.

What is the username that you use to login in Orchestrator?

The folder name is what you see here:


Go to QueueDefinitions on Swagger:<your user name>/<your tenant>/orchestrator_/swagger/index.html#/QueueDefinitions/QueueDefinitions_Get

Click on Try it out:

Then click on Execute:

Go through results searching for you queue name and get your OrganizationUnitFullyQualifiedName, this will be your folder’s path.

1 Like

Hi @alexandretperez
Thank you for your recommendation but when I entered that URL with my username and tenet name they say that tenet is not available ?

What do you mean by ‘your tenet’ in here ? Isn’t it the one that you can see in the picture below.

Thank You !

Hi @Rusira_Liyanage

Is this something that started happening now?

Are you not able to access orchestrator anymore?

Hi @alexandretperez

No , I am afraid . I can access the orchestrator.

But you cannot access the below URL right? (after you already logged in Orchestrator)

Give a try to "'s workspace" as your folder’s path.

Other than that, I don’t know what more you can do.

1 Like

Hi @alexandretperez

Hey buddy I just got solved this problem. I just removed the folder path and run the execution as usual. I could able to get an output from this workflow so a transaction item was fetched from the “Queue 1” in Orchestrator.

At earlier , I couldn’t get the transaction item successfully may be because of some synchronization problems with the Orchestrator. (Don’t know exact reason)

If a particular Queue is there in the tenenet , ‘My Workspace’ folder of the Orchestrator , we should able to get it at the studio by giving just the Queue Name as usual.

Anyways I think get Transaction Item Activity get an transaction item randomly from the Queue , which is at the Orchestrator.


Thank You !
Best Regards ,

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.