Get Text not working in Anchor Base


“Get Text” is not working with “Anchor Base” activity. Any alternative to it, please suggest.

Piyush :slight_smile:

Did you tried instead of using Anchor base just use regular Get Text + ‘Indicate anchor’ function in UiExplorer ?image

Hi @tilarapiyush

Please give some details to help understand the issue better. Try to isolate the issue by running just the activity alone.

Suggestion: Select the Anchor Base activity, mouse right-click, select Test Activity.

Alternative: Create a new sequence called it Test and copy only the anchor base, find element/image and get text activities. Re-create any missing values in new sequence called Test to confirm it is not related to UI synchronization issues, etc. Have the target application ready at your required screen. Run the Test sequence. After testing and getting the results you need, delete the new sequence called Test.

Integrated Anchor selector

I tried this, but it did not work.

I tried running the activity alone. In Anchor Base I used "Find Element " as anchor and “Get Text” as activity. But it is giving me some random value and not the exact result.

Instead of anchor base options, try with css selector option , so that get text along with css selector specification can be used.

Hi @tilarapiyush

On top of the other forum user suggestions, please use UiExplorer to examine the attributes/values for the text that you need. For example, innerText attribute, text, etc. If the attributes contain the value, you can substitute get text with get attribute.


I got the solution doing below steps.

Used ‘Indicate anchor’ function in UiExplorer (as suggested by @Ryba ) and then selected the CSS Selector attribute. Also I unchecked few attributes and used wild characters to make my selector more dynamic.

Thanx everyone for help.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.