Get specific content of queue item doesn't work

Hi all,

I’m encountering a problem while extracting information from a queue item using ‘getspecific content’.

I use ‘get transaction item’ and save it as a queueitem.
Then I try to extract information from the queueitem using an assign activity: (argQueueItem.SpecificContent(“variablename”).ToString)

This doesn’t work. It gives an error that says the given key is not present in the dictionary. But, I’m sure it does exist. See screenshots for more information.

Hope someone can help me!

Kind regards, Ties

Hi @Ties

Please do initialize the dictionary as new Dictionary(of string,string)

Ashwin S


Everything looks as it is correct, the given key not present means the key you are trying to access is incorrect or doesn’t exist.

What is the specific content you include when adding the queue item?
It should be identical to that - do you add any quotation marks or are there additional spaces?

1 Like

I believe it is the additional Quotation mark in the Key that is causing the issue. Can you please share a screenshot of how it appears in the queue?

1 Like

This is what it looks like when uploading. The key is ‘Startmonth’ and the value is a number as a string. As far as I can see it’s identical.



Please try argQueueItem.SpecificContent(“Startmonth”).ToString - Check the ‘M’ in month should be lower case. That is how it is in the specific content.

1 Like

This is what it looks like when uploading to the queue. The key is ‘Startmonth’ and the value is a number as a string. As far as I can see it is identical.

Thanks, but I already tried that. It doesn’t make a difference…


Please use “Startmonth” here and let us know how it goes.

I mean for this


The case of words has to be identical - either change the Add Queue Item to StartMonth or change the specificcontect extraction to Startmonth to match :slight_smile:

1 Like

Thanks guys, but I tried and it doesn’t make a difference. I get the same error.


Please remove the “” for the variables in the Name Column and try again

Also I see from the first screenshot image
The Specific Content is saved with the escape sequenced quotes.
So when extracting the data try using the same way

Startmonth surrounded by the escape sequenced double quote.

Remove the double quotes surrounding the key Name in the Item Information.
Recreate the queue and try the assign.


Thank you so much!

Removing the quotes did the trick. What’s weird is that in the first place (when I first asked my question to you), their were no quotes at all, so I don’t know why it didn’t work there.

But thank you anyway :smiley:


Part of the learning curve :slight_smile:
Good luck and Cheers.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.