Get Queue Item bug? "System.ArrayTypeMismatchException"

activities
error
#1

Hi,

I just tried the Get Queue Item and I’m getting the following error message:

System.ArrayTypeMismatchException: Attempted to access an element as a type incompatible with the array.

And it doesn’t work from UiPath.System.Activities version 19.2.0 and forward. This activity works perfect when I downgrade to package version 18.4.2.

Bug, or just me not understanding some new functionality?

/d

#2

What orchestrator version are you using?
How is get queue items configured?

#3

Using Orchestrator 2018.3.2.

Configured it just by using an input and output:

The point is, is that I have two separate projects; one using UiPath.System.Activities v. 19.2.0 (or 19.3.0), and the other one 18.4.2, and I use the same queue as input. One fails, the other one works.

Strange…

/d

#4

there is no difference in the activity between 18.4.2 and 19.2/19.3 so i think it may be orchestrator related. i will have to test it myself

#5

you should output the activity into a variable of type
image

#6

Double, triple, quadruple checked that it’s the right variable type.

#7

i ve checked with 18.4.4 orch and its working fine with 19.2 and 19.3

its the same queue you are using as target? is there any special character or something in a queue item?

#8

Same queue as target in both projects. No special characters unless “_” (underscore) is considered a special character, but I tried creating a queue with only alphabetic characters too. Did not work.

Can you try with Orchestrator 2018.3.2? That’s the Orch version I have.

Kind of leaning towards compatibility issues…?

/d

#9

Hi,
i am facing exactly same issue, is it resolved?

Thanks
Varun

#10

Hi Varun, what Studio version do you have?

#11

Same issue here, Orchestrator 2018.3.2 with Studio 2018.4.3 Package version 19.3.2

#12

Hi all - this appears to be the same issue as we are tracking here:

Has anyone had a chance to check if it’s been fixed in their environment with UiPath.System.Activities v19.4 yet?

#13

It has not resolved in UiPath.System.Activities v19.4 also