Get Transaction Item by Reference error

We recently made the upgrade to 2018.4.5. I am trying to pull a specific queue item using Get Transaction Item activity and requesting a specific Reference. I am consistently getting this error, although it works fine when I take out the string I have in the Reference property:

UiPath.Core.Activities.OrchestratorHttpException: Does not support untyped value in non-open type. Error code: 0

Get Queue Items still will pull the queue item data by Reference without error but it doesn’t start a transaction (setting it to In Progress). I read from another post that this is now in Uipath.System.Activities. My Studio package version for this is 19.3 but our Orchestrator library has 18.4.2. Could this be the cause of it, or any other ideas?

Thank you!

1 Like

Tried with Orchestrator 2018.4.4.

The error happens at the Orchestrator Service level (you can check this from IIS logs / Orchestrator server event viewer), so would indicate that there is either a bug in the activity or there are steps / installation required on the Orchestrator-end which has not been documented publicly.

Any comments from @UiPath would be appreciated

I am too seeing same error on trying to get a specific queue item using Get Transaction Item activity and with some Reference. Appreciate if someone could help here. Thanks!

I got a response from Support.

The short of it was that it is a future Orchestrator version feature and will never work on 18.X

So only option to get it working is to wait for Orchestrator 19.X release (and installation, depending on the update schedule of your organization).

In case someone from UiPath reads the forums, it is NOT okay to release activity packages without stating which versions of Studio / Orchestrator / Robot they are compatible with.

2 Likes

Hey there!

Sorry for the late reply, it’s been a tough couple of months.

I updated the docs to clearly state this fact, so that no more confusion arises.

Sorry for the inconvenience I’ve caused, and thank you for pointing out the reality.

Maybe some butterflies :butterfly::butterfly::butterfly: will make your day happier.

Cheers!

Hi @Tech_Scribe, Can you post the link of that doc here?
I am unable to find it.

Hi guys,

I am also facing the same issue in one of the pre-sales projects.I am getting same error while trying to get a particular queue item using the “Reference”.Is there any solution?I am using 2019.7.0 Community version.

Or Is there any other way that I can fetch a particular item from a queue?