Get Outlook Mail Messages: The specified folder does not exist (Account and Folder)


I have multiple accounts in my outlook and multiple folders. I tried to get messages from specific account and folder, unfortunately when one configure this activity with account and folder parameters, the activity throw an error “The specified folder does not exist”.
There is some strange thing, when I open the outlook before I use this activity there is no problem to get the messages with the same parameters. Furthermore I can get the same result also if I try to wait for this error message and run the same activity one more time.
It’s seems that there is some “bug” that the synchronisation of the application not ready yet and UiPath try to get messages before it’s ready.

I tried it with several computers (Win7, Win10), with several Outlook (2010, 365), with several Activity versions (1.7.2; 1.5 and 1.0.5543) and several Email accounts and the same result appear.

Is someone got the same problem and manage to get a solution?

Screenshot 2019-12-19 at 08.29.35


If your folder is sub folder , you have to mention the folder hierarchy.

Thank you for your replay.
I don’t have a sub folder.
As I said the problem not appear when I open the Outlook before I start the process, so the problem is not in my parameters


If you want to automate Outlook application then make sure it should be installed and should be in online.

It the application opened then you won’t get any error. You will get that error when it was closed only.

Sure, I already said that I opened the application and it’s configured with accounts and folders, so I have it installed.

Yes that exactly what I said.
The Outlook application doesn’t need to be opened to use the “Get Outlook Mail Messages” activity. It’s used the API of Outlook and work in background.
I don’t understand why only when the application opened before that I call this activity it’s works.
When I use this activity when the Outlook is close, but no folder defined, there is no problem. Only when I define account and folder it happened.