Get outlook mail message error fix


i get this error almost once a month and when this happens i have to create a new user account in my machine and reconfigure outlook and then it works fine for one or two more months before the error comes back.

im the only one in my team who’s facing this problem and it’s really hard to deal with and having to backup myfiles monthly and change my user account and reconfigure everything. a lot of people have reported this problem to the forum but nobody seems to have a solution. can anyone help from uipath???

Hi kamal,

I have also faced this issue,
have you defined the Account name?
Also try to inter the full path of the folder
for example :- \\Inbox\Folder

non of this works, the only thing that actually worked is me creating a new user account in my machine and reconfiguring outlook because when I reinstall outlook nothing works. windows keeps the user accounts and everything saved for the current account even if u remove the account manually and reconfigure it that doesn’t work too

the full SS of the activity.

@ovidiu.iliescu any idea?

We have only seen something remotely similar to this in the past with Search Folders, that are not properly synced with Exchange if running in cached mode. But this does not seem to be the case here.

The periodicity of it makes me think of MFA/2FA or some other authentication issue, where the token Outlook has is expired. Usually if you try to send an email from Outlook or try to refresh it or do something that will trigger Outlook to re-auth itself, the problem should go away.

I am having the same issue. It was working earlier and for some reason, the sub folder can no longer be found. Using Inbox of the shared mailbox works fine but referencing the sub folder shows folders cannot be found error. the work around I tried was encasing the getmail act in retry scope as I initially thought it may have been latency issues.
I do not suspect the mfa or authentication issues on this as it randomly happens. sometimes the subfolder found and there are instances subfolder not found.