GetOutlookMailMessages: "The specified folder does not exist" (Shared Inbox)

Hi all,

I have 2 environments and this works in one environment, but not in the other (it has earlier worked fine in both).

I’m using GetOutlookMailMessages to fetch emails from a shared inbox. This inbox has been added as a second account in Outlook.

It works to fetch the Inbox folder, however when I’m trying to fetch anything from a subfolder (“Inbox\TEST”) I get the following error: “The specified folder does not exist”

Fetching emails from subfolders works fine in the primary email account, so I’m clueless what to do now.

Any ideas?

When Get Outlook Mail activity is used it will try to configure with your machines installed and connected account in outlook app
So kindly ensure that tax count is having a folder named TEST under Inbox
Or if it’s a shared mail box kindly mention that in shared mailbox property
Cheers @P_S

Yes, it has that folder.
I also tried to create another subfolder named “ABC” in the shared inbox.
It still doesn’t work to fetch this subfolder.
I assume that if I see the folder structure “Inbox\ABC” in Outlook, this is what I should state as Input.MailFolder?

I tried to do the same in the main inbox, and it still worked fine.

So it’s something strange with subfolders in this shared inbox.

Fine
Can I view on the property panel of get outlook mail activity and also your mail inbox structure with a screenshot if possible

Cheers @P_S

This is the folder structure in Outlook:
Inbox

This doesn’t work:

This works fine:

Kindly remove the account value in the property panel with the property Account and try once with the subfolder path provided in folder property

Cheers @P_S

Didn’t unfortunately work, and removing Account property it then also don’t work if I as MailFolder only set the inbox named “Inkorgen” either.

I think this then will go for the main email account?

@P_S,

I saw your uploaded screenshots, I can see that TESTER RPA contains subfolder inside it.

Inkorgen is main folder just like inbox which already contains email inside it , so when you give “Inkorgen” in Mailfolder ( properties pane) it works.

But on the other hand TESTER RPA is just a simple folder. I would say keep the account name as it is, in MailBox property specify full path to folder from where you want to read mail, like this… “Inkorgen\TESTER RPA\TEST”

TEST being subfolder of TESTER RPA.

Hope this helps…

Regards,
Ahtesham

Actually “TESTER RPA” also contains emails.
I tried with something like this as well “Inkorgen\TESTER RPA\TEST”, but it didn’t work.
I also tried to create a new folder “Inkorgen\ABC”, that also didn’t work.
Any more ideas? Can there be a setting in Outlook that need to be done?

@P_S There is no setting as such which need to be enabled.

I have worked on similar situation like you ( multiple mailbox account) but this kind of error I didn’t face.

Only two things are there in get Outlook mail activity.

  1. Account ( which you are already giving)
  2. Proper folder path of mail box from where you.wnat to read mail ( which you have already given)

Other than these two I don’t think there is anything…

I tried to replicate your situation , it worked for me…

I am not getting any error.
Can you please once again share exact folder structure . I will try to replicate it and can unblock you .

I want to give you example , suppose you have to read from Temp ( subfolder) . then you need to put mailbox property as “Inkorgen\Error\Temp”

Ahtesham

I have another virtual machine, where I’m using the exact same shared inbox and it works perfect there (to fetch the exact same folder). However, In that machine I have not added this inbox as another account - but it has been given permission via the Exchange Server (? I’m not an expert on this, so not sure exactly how this is configured in Exchange).

In the machine I’m facing this issue, I have added the shared inbox as another account. That’s the only difference.

So I’m clueless in why it works in Machine A, but not in Machine B.

@P_S, Can you please give the folder structure screenshot of both virtual machine so that I can figure out some solution.

I know you have described the folder structure but I would insist you please provide the folder structure screenshot

Ahtesham

1 Like

Thanks for trying to help! Much appreciated!

This is from Machine 1, where it works fine (the shared inbox have NOT been added as another email account in Outlook, but permission has been given to the user to that shared inbox).
works

This is from Machine 2, where it does not work (the shared inbox have been added as another email account in Outlook)
not_working
Here it works to read from the folder “Inkorgen”, but not “Inkorgen\TESTER RPA”.