Get jobID from Orchestrator

Hi!

Is there a way to get the JobID of the job that is executed in Orchestrator from the UiPath Studio?

Hi @Cutro

Welcome to uipath community
hope this would help you
https://forum.uipath.com/t/how-to-get-details-like-jobid-robotid-windows-username/2980/9

Cheers

Thanks!
I check that but I’m not sure if that’s the solution. The activity Get Processes doesn’t have the jobId of the Job that Orchestrator is executing. And the “UiPath.Executor.ExecutorManager.Instance.Id.ToString()”, as they said, UiPath.Executor is not a member of UiPath.

Is there another way to get that JobID?

I am also facing same issue, Did you find any solution?

Hi,

I found a way to get the JobId of a Running process by using the Orchestrator API. This solution relies on the bot having access to reading Jobs info in Orchestrator, so if somehow this is not possible, this solution won’t work.

It basically uses an http GET request to get all the Jobs that are Running on the specific machine the bot is running. Then, the ‘key’ value that comes in the JSON response is the JobId of that process.

Here is the GetJobId.xaml (8.6 KB). To deserialize the JSON response, I used the ‘UiPath.WebApi.Activities’ Dependency. So the Missing Activity that might show you comes from that Package.

If you want, you can check all these other handy requests. And if you want to know how to use query parameters in those requests, uiPath follows OData’s URL Conventions. You will find everything you need to make your queries there.

I hope this will be useful. Cheers!

1 Like

Hi @Franco_Giulianini

I have downloaded your .xaml file to try but the activity is missing despite me having updated the relevant packages. I am getting the error

“Could not find member ‘ResponseHeaders’ in type ‘http://schemas.uipath.com/workflow/activities:OrchestratorHttpRequest’. Row: 67, Column: 566”

Do you know how I can fix this? Or failing that, could you provide a screenshot of your parameters please?

Thanks in advance

Hi @Franco_Giulianini

I am having the same issue

Please can you share you parameters and I can add them locally

Thanks

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.