Get credential activity issue

Hi,

I am storing credentials in assets in orchestrator. Through get credential activity i am using those credentials in code. The bot is able to fetch username but not the password. I am using type secure text activity for typing password. Still the bot is not picking up password correctly. What could be the issue?

Thanks.

Hey @mannu.1996.08, Have you tried printing the password to check whether it has expected value ?

@mannu.1996.08

Not picking up means, Are you facing any error?

If so share the screenshot

Thanks

i tried printing it through message box but getting value as secure.string. How can i print? please suggest

1 Like

not error. while logging it is showing that credentail is invalid. as i tried printing username and password both, it is printing username but not password . so i understood that it is unable to fecth password

@mannu.1996.08

Declare a string variable and give as below
new System.Net.NetworkCredential(string.Empty,YourPasswordVariable).Password

Hope this helps you

Thanks

2 Likes

Could you please try printing the below…

System.Net.NetworkCredential("", <secureStringPwdVariable>).Password

Thanks :slight_smile:

i took a new variable and used the expression that you provided. And then passed that variable in the password field. it is working now.

Thank you. @ksrinu070184

1 Like

i tried with this expression but not working in my case.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.