"For Each Row" activity not working properly recently

Hello,

I hope I am putting this question in a proper category. If not, admins please feel free to move it elsewhere.

We are using one automation for last 3 years and until recently it worked flawlessly. We take data from excel (order containing product IDs and product quantities) and fill it into invoicing software.

Problem is, that at some point the automation breaks and product ID is inserted in the wrong column in invoicing software. We believe the problem is in the broken “For Each Row” activity.

I’m attaching a video describing the problem:

0:20 - robot starts filling product ID and quantity into invoice software
1:10 - robot breaks and starts to fill product ID into “price” column

This error varies , sometimes the robot breaks after 10 rows, sometimes after 50 rows.

Can you please advise what could go wrong over the years? First two years the robot worked without any single problem. Now it’s almost a rule that longer orders are experiencing errors. We need to restart robot sometimes 3-4 times to get job done successfully.

I’m attaching automation and order file in excel. You can find them here: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

Thank you everyone for help.

It doesn’t look like a problem of F-E.
It is more likely problem of the app - it doesn’t keep up with the speed of robot’s typing.
Slow down the process by adding some delay before/after each field.

Cheers

Yes I added a delay at the end of For Each Row activity, but it still didn’t help. However we are using this automation since 2018 and always worked even on slower computers. Problem started occurring in the last few months :frowning:

In the screen recording it is clear that before the failure the bot should type product code but the code doesn’t appear in the field (1:11). Then it moves to the quantity and types 3 (1:12). And then the process collapse - maybe because some mandatory field is missing.

I would recommend to validate the content of typed-in field before moving forward.
Actual implementation deppends on your app, typical approach is like follows:

  • type the value
  • select all, Ctrl-A
  • copy, Ctrl-C
  • compare clipboard with expected value
  • if not match clear the field and enter again

Cheers