Find Files And Folders: Code: generalException Message: An error occurred sending the request - account property empty

I have used this activity in a previous flow for a different SharePoint site and it has worked so unsure why I am getting this error message - I am the site owner for this current SharePoint site. When I run the activity the account in the locals panel is empty - not sure if this is related?

Hello @E.T.S, try some of these steps and see if it works:

  1. Check Permissions: Ensure that your account (the one running the UiPath workflow) has the necessary permissions to access the SharePoint site and perform the actions you’re trying to automate. As you mentioned that you are the site owner, you should have sufficient permissions, but it’s essential to double-check.
  2. Account in Locals Panel: The fact that the account in the Locals Panel is empty may indicate an issue with authentication. Make sure you’re running UiPath with the correct credentials, and the Robot running the workflow has access to the SharePoint site.
  3. Verify SharePoint URL: Double-check that the SharePoint URL provided in the activity’s properties is correct and points to the right SharePoint site, document library, or folder.
  4. Authentication Method: Depending on your SharePoint setup, you might need to choose the appropriate authentication method. SharePoint supports various authentication methods like Windows Authentication, Form-Based Authentication, or OAuth. Ensure that you’re using the correct method for your SharePoint environment.
  5. Proxy Settings: If your network uses a proxy server, make sure the UiPath Robot is configured to work with the proxy settings, if required.
  6. Update UiPath Packages: Ensure that you are using the latest version of the UiPath.UIAutomation.Activities and UiPath.Web.Activities packages. Sometimes, updating these packages can resolve compatibility issues.
  7. Try with Different Credentials: If you’re still encountering issues, try using different credentials to access the SharePoint site. This can help identify whether the problem is specific to your account or a broader issue.
  8. Logging: Enable detailed logging in your workflow. This can help you capture more information about the error, including any specific error messages or stack traces that might provide clues about the problem’s root cause.

Cheers! :slight_smile:

Thank you for your reply! I am trying to add another account as a site owner with full control in SharePoint but this only allows me to add the account as a limited control member - I think this may be the issue - would you know how to rectify this

Try something along these lines:

  1. Check Current Site Owners: Ensure that the existing site owners have not restricted permissions for adding new site owners. Sometimes, existing site owners may have modified the permissions to prevent others from adding new owners.
  2. Verify Site Collection Administrator: Site Collection Administrators have full control over the entire site collection, including the ability to manage site owners. Make sure you have Site Collection Administrator privileges for the SharePoint site.
  3. Check Permission Levels: SharePoint has predefined permission levels, such as Full Control, Design, Edit, Contribute, and Read. Ensure that the account you’re trying to add is assigned the Full Control permission level at the site or site collection level.
  4. Site Collection Settings: In SharePoint, go to “Site Settings” > “Site collection features” and ensure that the “Limited-access user permission lockdown mode” feature is deactivated. This feature can sometimes restrict permissions.
  5. Security Groups: Instead of adding individual users as site owners, consider adding them to security groups, and then assign the security groups the necessary permissions. This simplifies user management.
  6. User Information List: SharePoint maintains a “User Information List” that stores user details and permissions. If there are issues with a user’s profile or permissions, it can be helpful to delete and re-add the user.
  7. Check for Policy or Restrictions: Some organizations enforce policies or restrictions on SharePoint permissions. Check if there are any organization-wide policies affecting site owner permissions.
  8. Site Collection Deletion: If the SharePoint site collection was previously deleted and then restored, it could result in permissions issues. In such cases, it might be best to recreate the site collection.

Cheers! :slight_smile:

I managed to give full control thanks! however I am still getting the error message Find Files And Folders: Code: generalException
Message: An error occurred sending the request

Try some of these steps and see if it helps you:

  1. Retry the Activity: Sometimes, transient issues can cause this error. Try running the workflow again to see if the problem persists.
  2. Check Activity Configuration: Double-check the configuration of the “Find Files and Folders” activity, including the SharePoint site URL, folder path, and any other parameters. Ensure they are correctly set.
  3. Log Additional Information: Add more logging activities to your workflow to capture additional information about the error. You can log the SharePoint site URL, folder path, and any relevant details before the “Find Files and Folders” activity. This can help you pinpoint the source of the issue.
  4. SharePoint Service Status: Check the status of SharePoint Online services. Sometimes, issues on the SharePoint side can affect automation processes. Ensure that SharePoint Online is operational without any known outages.
  5. Network Connectivity: Ensure that your machine, where UiPath is running, has proper network connectivity to the SharePoint Online environment. If there are network issues, it could result in this error.
  6. Retry and Exception Handling: Implement retry mechanisms and exception handling in your workflow to deal with transient errors. This can include retrying the activity a certain number of times before giving up or handling specific exceptions that may occur during the activity.
  7. Check for Restrictions: Ensure that there are no restrictions or firewall rules in your organization’s network that might be blocking access to SharePoint Online services.
  8. Test with Other SharePoint Activities: Try using other SharePoint activities (e.g., uploading a file or checking permissions) to see if they work. This can help determine if the issue is

Cheers! :smiley:

Hello, I’m facing the same issue. Has anyone discovered a solution? I tried following the tips provided by @rodrigo.simao, but unfortunately, it didn’t solve the problem. It’s possible that this issue is related to a Microsoft library problem or a bug. This problem appeared at the beginning of September.