Filter data table error: the value for argument "Column Name" is not set of invalid

I have a filter for a column “KNVV BlBlk”

image

For some reason, the bot throws error that this column does not belong to the table, even if it belongs

I don’t know what it can be, maybe the font is not recognized.

Please help

The same error message if I use other column names, basically for any column that I want to filter the same error message

image

Even if I use a different method of filtering, error is the same, although with a bit different wording

image

Hi @raool90

Check the Column, if it has any space in it and check that have you read the correct excel file.

Regards
Gokul

Hey @raool90 there might be some spaces in the column name please trim it or you can give column index in place of column name…
Thanks and Regards.
Sreejith

You can use the index instead of name

1 Like

typical spaces, linebreaks can confuse the name, but visually not identified on a quick check

can be the reason as mybe addHeaders was not selected for the read range and the auto generated column names are in use

debugging and inspecting the the datatable within the different debugging panels is the recommended analysis step

Understanding the 6 Debugging Panels of UiPath in the easiest way possible!

give a try at: (immediatepanel)

YourDataTableVar
check the header line

YourDataTableVar.Columns