FAQ Common license errors

My community version license has expired and I have tried all the above methods to renew, but it’s still not working. I have installed only community edition in my device and never installed other versions. Can you please advise?

Device ID: vzZGuwzsbGhejfmnabeY

1 Like

Same over here,
Can not reactivate my community license:

Activation failed with error: 0
Error description: No Error
License status: Device ID already activated, trial not allowed after code activation
Device ID: eYWoESifcWwoN6Q9ipOp

1 Like

Hi Tom,

Your Device ID is linked to a trial code that was activated on 24th December 2017. That’s why you cannot activate Community Edition(Start free option). Please reach out to support: Contact Technical Support


Hi, I have the issue “SOAP host can’t be resolved”.

As explained, it’s due to a firewall issue.

I can make a ticket here to ask for access to the activation server but I wasn’t able to find wich url/ip (or something else) is needed. Uipath website is accessible considering I managed to download the installer.

Thanks in advance

Please check the Robot documentation link in this post:

1 Like


I have reinstalled my UiPath and still get the error “SOAP Connection timed out”
I can’t see any solution for this one here :confused:
I am attaching the screenshot of this error.


If anybody is able to help me I would be grateful.

Thanks in advance.


Hello Guys,

In my case the only thing that I had to do was switch to my mobile network.
After connecting with my mobile as a hot spot I was able to activate the CE license.
Btw. it worked for both CE .exe file and .msi file.

Hope it will work for you as well.

Best Regards,

1 Like

Very good post, it will help most of the beginners

1 Like

Hi, I have tried using my mobile network, however I still can’t activate. Please help urgently!



Hi @cclam81

Have you tried whitelisting the licensing server my.nalpeiron.com? You can find details in this page of the Robot user guide:

Hi @ovi, I just tried whitelisting my.nalpeiron.com on my Windows firewall, if that’s what you mean. However, I’m still facing the same result. Not sure whether I have missed anything here. Please help. Thank you.

Try to delete the License folder from %localappdata%\UiPath, start Studio again and try to activate.

Tried a few times but still unable to activate. I have already whitelisted the licensing server. Even tried disabling firewall. All of this is done using my mobile network. Please help. Thank you.


Same here,

It says i have already used the trial version when is my first time installing CE.

Device ID : IzcirznRTCyaLYg9f4xA


Please Ovi:

Error description:
“Cannot use Community Edition on this machine after activating a trial or Enterprise license code. Please enter a valid license key.
License status: Device ID already activated”

In the link " Contact Technical Support" say “Community Version users: Community Edition is provided by UiPath free of charge and we don’t offer support for it on our ticketing platform. Any inquiries from personal email addresses won’t be answered.”

Please your help :frowning:

Did you previously have a Trial license on the same machine? Are you using a VM?
Please provide your device ID.

Yes, on the machine I had a trial license. I do not use a VM.

Activation failed with error: 0
Error description: Cannot use Community Edition on this machine after activating a trial or Enterprise license code. Please enter a valid license key.
License status: Device ID already activated

Device ID: FI+r7IStwfyNxc17sdC/
Computer: PP01TCSPROAFP07
User Name: S80269

Please your help :frowning:

Hi Ovi,

I am experiencing the same issue as hapari_ch. I had previously downloaded the trial version of UIPath on my personal computer because I was part of a test user group for my organization to determine whether or not we wanted to purchase UIPath. My organization has since purchased several UIPath licenses for use at work, but I am now wanting to download the Community version onto my personal computer to program things for the Hackathon. (Corporate policy does not allow me to use my work computer to program for the Hackathon.) Unfortunately, since my previous Trial version of UIPath has now expired, I am getting the following error whenever I try to activate my Community version:

Activation failed with error: 0
Error description: No Error
License status: Server License Expired

My device ID is Bpxntv2j+aS2pUwHmWeG.

I would very much like to participate in the Hackathon, so please let us know what we need to do to resolve this!

(I have also submitted this as a request via the Contact Technical Support link, but as hapari_ch pointed out, the website says they will not respond to any inquiries from Community Version users, so I do not expect to receive a response there.)

Thanks in advance,



I’ve never had a trial licence. I’m using community edition. I renamed my licence folder and submitted several requests to


I’ve restarted my PC so nothing UiPath related is initially running.

When I relaunched I did generate a new licence folder but I get the following message.



and opens up the licencing webpage UiPath

So I enter my Device ID) 4D69*****---****-********7DA


And then fill in my email address in UiPath window to register


When I press activate I get


Please can someone help me out with this as I can’t do anything at this point.

This is my previous post regarding my attempt at renewing my licence.

Many thanks,