Extracting and entering a each URL in webpage

I have a webpage which i need to extract the URLs of, and for each URL, go in to perform a click in order to download a file.

I did the following:


The first iteration for item was ok. I managed to download the file. However, on the next iteration, it is stuck at the Get Attribute function (which is ‘href’), leading to an error.

I am not sure what the issue, as running the debug shows the correct selector (as compared to the one shown in UIExplorer).

Help !


Can you place a log message after the get attribute and check whether all the extracted urls are fetching are fetching are not

Please let me know if you face any issue

May I know which kind of log message should I use?

What is the error? Details please.


Place a log message as below in the get Attribute

and pass the output of get attribute in the log message


I notice your Find Children has ‘A’ in the name. I’m guessing when you indicated for that activity you clicked one of the links. That’s incorrect. The Find Children needs to be given a selector for a PARENT element that CONTAINS all the links. Then you add tag=‘A’ to the Filter property of Find Children. You also should set it to FIND_DESCENDANTS for this.


This is my settings for Find Children. Odd that it only works for the first link?

1 Like

I did the Log Message but it didn’t print anything. Instead I received this error:



can you check that output of Find Children Activity that how much values you are getting

Above For Each activity check the output

and later change the waitForReady Option to Complete in the properties of Get Attribute

Running debug, I got UiElement[24], which was correct, total links = 24.

The selector is same in format as the first link, just an increment of the ‘msg_6030’ to the 2nd link: webctrl parentid=‘msg_6031’ tag=‘A’ />"

I have changed the Complete for Get Attribute


Is it Worked for you making use of get attribute to complete

Nope it doesnt. Not sure what is missing.

Interestingly, previously it worked. After coming back to this a month later, it broke. Odd !


can you replace and try with the same activities by indicating the web page once again