Extract Structured Data not working - returns empty data table

Hello All,
Extract Structured Data activity is returning empty data table. This activity was working fine the studio version “19.10.1.0”, but not working in the studio version “2021.10.5”
UiAutomation Package version is “[20.10.6]”,

Workflow is trying to extract table from SAP

Hi @manirathnam.murugesan

Can you check your variable panel that you have same variable name in different scope like?

image

Click on youe extract Structured data activity and open the variables and check for it and also can you check the selectors of the extract structured data activity too.

Regards
Sudharsan

Regards
Sudharsan

Do you have any error while processing. Share the screenshot of the XAML file.

Downgrade the UiAutomation Package version is 22.4.7 and check it @manirathnam.murugesan

Tried downgrading the package to 22.4.7 - still not working

Share the screenshot of the issue @manirathnam.murugesan

There is only one variable and in right scope, Selector is also fine - validating in green.

Can you do a new datascrapping for testing and check whether you can see the preview table? @manirathnam.murugesan

Tried new data scrapping and for this getting the error - “The method or operation is not implemented.”

Can you share the table screenshot from SAP ?

Uploading: UipathExtractDataSAP.PNG…

Sorry unable to upload the image

Sorry unable to upload the image