Exchange Exception

email

#1

Hi,

I have recently upgraded UI Path to v2016.2.6253 (13/02/2017) and now my Get Exchnage Mail Message is throwing the following error. UiPath.Mail.ExchangeException: Value cannot be null

The properties of the activity have not changed and I do not see any new properties for this activity. Is there an issue with this or has something changed that I am unable to see


#2

I have caught the exception and the inner message is Value cannot be null. Parameter name: address


#3

Hello!

Have you tried to exclude the Activity and then build it again?

Regards,


#4

Yes I have tried this and I get the same error message


#5

All the email packages are up to date? Try to update all the activities packages from “Manage packages” painel


#6

Its all auto update and are all up to date


#7

Unfortunately I don’t have Exchange so I can’t really test this for you but if I just run the activity with no information I get a pretty ugly error message.

@badita could you please confirm that Exchange Email Activity is working as expected on the latest version?

However, the error Andrew is getting implies that there is a problem resolving the Email Address because it has a problem with the Address parameter. Having said that the error messages do not always match the problem exactly.

Richard


#8

adding @Gabriel_Tatu


#9

what exchange version are you using? we have a known issue that we are trying to fix with 2016.


#10

I generally get the iSerializable error when using incorrect user details. Just to confirm I have had another member of staff run the workflow from their machine (Not upgraded to latest version of UI Path) and the workflow run fine. There is another difference in that I have been migrated to Office 365 where I don’t believe the other user has. We are re testing this today to see if it is related to my migration first

@Gabriel_Tatu sorry just seen your response. Not too sure if when moving to Office 365 if that changed what version of exchange I am using but potentially could be hitting this issue


#11

maybe you have another exchange server to test, 2013 or older, on premise would be perfect.


#12

@Gabriel_Tatu I have tested with 2 other users, the first has not been migrated to office 365 but is on the same version as me for UI Path (2016.2.6260) and the workflow runs fine. The other user however has been migrated to office 365 but is on version 2016.1.6075
Not too sure if this helps at all


#13

thank you very much, we will investigate


#14

I’m not an expert on Exchange but we currently use Office 365 and I thought that it was cloud based. To get it to work I use SMTP settings as per the following:

Apologies if that doesn’t resolve your problem.

Richard


#15

Hi,

I have come across a similar issue regarding this.
I am using the SMTP mail message activity and all the server settings and port settings are correct.
I am getting this error message:
Feil

However the adress parameter (to) is set when the activity is executing:
Locals

Has anyone experienced this issue?

Please let me know!

Edit: I have also tried to hardcode in my email address and getting the same error…
I have also tried running the process on a test server via orchestrator and then i am getting this error:
System.FormatException med melding: The specified string is not in the form required for an e-mail address. ved kilde: Send SMTP Mail Message

Edit #2:
Found a solution to the problem. Apparently I needed to add email address to the Sender - from property. It is a bit weird because I have used this the SMTP activity before and not needed it…
If anyone has experienced something similar and have an explanation, please share :slight_smile:


#16

Hey Richard, have you or any of your clients gotten E-mail notifications from the orchestrator to work using smtp.office365.com? I would love to see the orchestrator config to make certain we have it right. Then I could chase our Exchange folks.

Chris