Exception from HRESULT: 0X800A03EC

excel
activities

#1

Scenario:

I created a workflow on Friday including several Excel Application Scopes containing workpaths to files like:
“CL\CL Monthly Life Report “+month+” “+year+”.xlsx”
(month and year being defined variables and CL one of my folders).
This worked well on Friday but now that I open it 3 days later the following exception is thrown on all Excel Application Scopes:

I can’t find a working solution in the internet so far and tried already several steps like re-installing the excel package and re-entering everything.

Any ideas?

Steps to reproduce:

Current Behavior:

Expected Behavior:

Studio/Robot/Orchestrator Version:

Last stable behavior:
Last stable version:
OS Version:
Others if Relevant: (workflow, logs, .net version, service pack, etc):


Excel app. Scope exception: HRESULT 0x800A03EC
#2

Check whether the excel is open or not while running the bot. close the excel while running the bot


#3

Just going from your description (that it worked on Friday, but not today) could it be related to now being on October rather than September?

Is there a file path called “CL\CL Monthly Life ReportOctober2017.xlsx?


#4

Unfortunately the month isn’t the problem there as I adapted it…
Somehow just the workflow leading to one folder could be recognized…
I now put everything in there and it works… but I don’t really see the sense behind it…

Thank you for trying to help me!


#5

Hi,

Could you share you workflow and workbook deleting confidential data?
This could be very helpful for people trying to help you on that.

Cheers


#6

@BikashPanigrahi @PJ_17 I am also experiencing the same issue this morning. Exactly the same Error.
when the excel scope sequence is run individually it runs fine, the moment the excel sequence has to start as part of a bigger workflow it throws the error.

NB: when it is part of a bigger workflow and I put a break point on the Excel scope sequence, and manually release the break point to continue the run, it works. but it throws the error when running normally


#7

@lucabottacin @PJ_17 @BikashPanigrahi, I have found the solution to the excel error in discussion and I will try to be as precise as I possibly can.

In my scenario I am exporting a macro enabled excel workbook from SAP to local disk.

I Perfom formating operation on the locally saved workbook,

save the file with a new name

and read from the new file

and write it to another file

Solution in my scenario!!
what was I doing wrong?

I kept the excel activated SAP report Open within SAP whilst I tried to open the locally saved excel SAP report.
for some reason, Uipath does not like that I have not exited the SAP report, prior to opening the locally saved file.
So what I did was to add a few activities that exited the SAP report (I jut used a type into with the SAP short cut = “/n”)
And then after the SAP report had been exited I tried to allow the flow to open the Excel and voila it worked.

So the take here for all other developers experiencing the same error issue is to exit almost all excel like report related to the your workflow. Meaning the excel you are trying to open should be the only one on the screen. Probably other excel workbooks can be opened but should not be related to your current work.

Now, how did I figure it out?
I tested with Start process activity and and I told the Start process activity to continue on error, and i discovered that there were links in the locally saved filed from excel, trying to access the SAP excel file which stayed opened. So by exiting the SAP excel activated report the links were broken, and the locally saved file was able to open.