Excel Save As Type Combo box

I’m trying to save a file in Excel in xlsb but when I program the steps in UiPath it doens’t seem to recognize the combo box selection in ‘Save as Type’

The problem I have seems to be in the combo box as I’ve highlighted below

When I run the process, even thought he xlsb is selected, it seem like in Excel the format is still showing as XML

I tried adding a tab after the combo box to confirm the selection in Excel, but it doesn’t seem to make a difference.

Any ideas on how to make it work?


While type into the file name give test.xlsx with extension, it works

I need binary. @rajsekhar the files get corrupted if I save them with binary extension or I get continuous error messages

i not sure about binary files, but i used to save csv to xlsx , did n’t face any issues

1 Like

I managed to resolve it thanks to @Uemoe using the Export window in Excel.

Quite a lot of steps and I don’t know yet why the combo box is not working :pensive:


try using * Binary *(without the spaces).select item accepts wildcads.

Hello @rajsekhar.
How did you do it?
Thank you,
Camilla :slight_smile:

HI Camilla,

once we click on save as button pop up window appears

1.Activate pop up
2. type file name with extension in the file name box(example.xlsx)
if we want , save as type is xlsx also can change using select item.
3. set focuse on save and click


I was having the same problem as selrac. My fix was to type “E[k(enter)]” into the “Save as type:” combo box. I wanted to save Excel Macro-Enable Workbooks. That seemed to trigger the Excel UI to change the file type and file extension automatically from “.xlsx” to “.xlsm.” Selecting the file type in the list from the “Save as type:” doesn’t work. And typing the entire file type name doesn’t work either.