Excel Changing Save As Type doesn't actually change the type


I’ve got an xls file which I want to save as an xlsx file.

If I go into the Save As dialog and use either select from or any combination of clicks to select Excel workbook using UiPath the type that it will be saved as doesn’t change and the file saved remains as Excel 97-2003 you can see from this screen shot that the files displayed are Excel 97-2003 even though the type drop down has been changed.

However if I do it manually it works (which obviously doesn’t help me) here you can see

Here is the component


(upload://mDCizXCJU843tNROE1UWZZ4cfsq.zip) (10.2 KB)

Any advice would be appreciated.


1 Like

Is your BOT selects the “Excel Workbook” option in Save as window

Yes, I’ve tried various combinations of clicking and select item and when the bot selects the ‘Excel Workbook’ option from the drop down it’s as if that hasn’t actually been selected so the list of files remains Excel 97-2003 and if I then save either manually or via bot it tries to save in the original format .xls rather than .xlsx which is the type that has been selected in the dropdown.

If I was to do this process manually it would work fine so it’s not the Excel (as far as I can tell)

Not sure what option you are using to save as it .xlsx type.

Open the desired excel file using excel application scope, then send hotkey as F12 to invoke save as, then use “Select Item” activity to select the “Excel Workbook” option, may be that selected as the default option.

Then try to save it in a different path and check by passing a new file name.

That is exactly what I did (in one of my attempts except for the F12, I got to the save as through the menu options and I didn’t change the name but all that does is save it as a .xls with a different name).

Have you attempted this and the same thing doesn’t happen for you or are you making a suggestion on how you think it should work (which is how I think it should work also but it doesn’t)

Attached is my workflow and the .xls file that I am trying to convert from .xls to .xlsx I have changed the name as you suggested and used hotkey F12 instead of going through menu but just saves it as an .xls with different name as before.

Does the same thing happen to you?

ConvertExcelFromXLS.xaml (31.0 KB)

MyFile.xls (24.5 KB)

You will have to change the in_Filename argument to whereever you put the .xls file

Not able to open this xaml, getting error as

Type 'http://schemas.microsoft.com/netfx/2009/xaml/activities:InArgument(WaitForReady)' is not assignable to type 'http://schemas.uipath.com/workflow/activities:WaitForReady' of member 'WaitForReady'. Row: 127, Column: 28

Which version of UiPath you are using

CE 2019.10.0

This is the workflow I am using there are a couple of activities above but they are just to check file passed is an .xls file

Tried the same, looks it is triggering to .xlsx format when we doing it manually, but not from the BOT. Need to check on this, may be issue with the version 2019.10

1 Like

Thanks for looking into this.


Check the attached xaml, we need to have a click before the selected item activity. Then it is working fine.

ExcelScopeCheck.xaml (23.9 KB)

You are a genius!

It does seem odd that the select item should require the drop down to be clicked on to activate it, right?

Maybe the select item should have the click imbedded as a property of itself (which could be activated by check box, if there was any reason for it not to always occur before the value is selected.)

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.