Excel exception- Is it possible it was moved, renamed or deleted?

While writing in excel i’m getting following error -
Write excel Sheet: Sorry, we couldn’t find D:\xyz.xlsx. Is it possible it was moved, renamed or deleted?
though file is created.
Could anyone please suggest the solution.
Thanks in advance:)

1 Like

It is not recognizing the file in that path @Shree_Vybhavi

I hope you have provided the exact path , but there will be some spaces in the file name or may be some other reason

Instead of giving the path manually, just browse the file path. It will rectify the error

1 Like

yes @HareeshMR i’m giving excat path. I’m passing the same argument to both file creation and for writing same excel.

1 Like

Even if i open the file manually it is saying the same error:(

Hi @Shree_Vybhavi

Agree with @HareeshMR. Also check whether you have a good connectivity if you are writing the data to a file that’s available on a remote shared drive. Sometimes when writing to remote file locations can cause such issues too if you have a slow connectivity

3 Likes

Please don’t create the file using create file activity @Shree_Vybhavi. That won’t open the excel file at any cost . Don’t know the issue.

Instead you can create the excel file automatically on the run by checking create new file in the excel application scope property and write the data in it using write range :slight_smile:

Is there any specific reason for not using Excel application scope?

sorry file creation i meant was by creating through excel application scope itself.

That was strange. Can you delete the existing file now and check if there are any excel files running in background opening the task manager @Shree_Vybhavi

If there are nothing, then try creating again

Hey bro @HareeshMR

Just bit confused…
We can create the file first using create file activity. Then use the excel application scope to open the newly created file right?

Isn’t that working in this case?

2 Likes

Fine
kindly try creating the excel in some other DRIVE folder apart from D:/
i have a small doubt on it
kindly recreate and try once pls
Cheers @Shree_Vybhavi

1 Like

Yes we can do that @Lahiru.Fernando,

but when I tried it, the file is not at all opening. It is giving me some error even when I tried to open it manually. Don’t the exact issue. That’s why I asked her to do in another way

Hmm that’s weird :thinking:

I thought we could do that… let me try it as well…

2 Likes

Yeah, please let me know if it works @Lahiru.Fernando :slight_smile:

Sure will do bro :slightly_smiling_face:… just curious to know why it’s not working :grinning:

2 Likes