Excel Application Scope - changing file location string

Hi all,

A bit of a strange one. All im doing is trying to create an excel file (for a report) using excel application scope.
However, it an error occurs as it cant access the file…looking at the error it seems as if the file part of the string is being changed within Excel Application Scope…

(Pic 1: View of workflow - assigning “C:\Users\CO\Documents\RPA\Report Extraction\Jul 2019\Extraction Report.xlsx” to string)

(Pic 2: Message box with the correct value)

(Pic 3: The error - note how the file part of the string changes to some random value…)

Does anyone have any idea as to what is happening?

Additional info:
AutoSave and CreateNewFile are the only options set true in the properties of Excel Application Scope

Hi @calOn8 ,

I tried replicating your issue. I got the exactly the same error message.

Make sure that all directory up to the filename are created. It is throwing exception because all directory does not exists.

This usually occurs when you’re doing some operations on Excel which is opened.

Close the excel file and try the same.

Hi @Rahul_Pasupuleti

I have no excel applications open when the error occurs.

Hi @Rohit - I think that may be it, the file path was wrong. But the error showing up with that random alpha-numeric value through me off so much that I didnt double check and thought it was a UIPath or activity error


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.