Excel Application Scope RPC_E_SERVERFAULT


#1

Receiving above error upon trying to execute an EAS activity.

“Excel application scope : The server threw an exception. (Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))”

I’m getting this with multiple files (both .xls and .xlsm). Thing is that this worked fine up till a few days ago. Interesting factoid is that I can see an Excel process being instantiated, and that this process apparently is opening the file, because I can see an entry for a temporary working copy appearing in the directory.

This series of messages appear in the output window:

Excel application scope Executing
Excel application scope Faulted
Excel application scope : The server threw an exception. (Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))

I’m at a complete standstill with this. Any enlightenment appreciated.

ddk


#2

Please try once with workbook activity.

I have also faced issues with Excel scope.
I cannot help resolve this particular issue.
However, suggest you to please try once with workbook activity.


#3

please check your excel activities version and update, few bugs were fixed in later versions.

i am not sure. please give a try


#4

Thanks for the responses. I had tried removing and reinstalling the Excel Activities, and that didn’t help. Workbook functions were working fine… in fact this particular XAML is using both Workbook and Excel Application Scope in different areas.

Anyway, this morning I uninstalled and re-installed UiPath, and now it’s working. Still have no idea what caused it to go bad a day or two ago, but whatever it was, reinstalling appears to have taken care of it.

ddk


#5

I asked you to update your excel activities to newer version. Anyway happy… your problem was solved


#6

No, I spoke too soon. I got one good run, and since then back to the same old.

One that I forgot to mention was that yesterday I sometimes did not get the EAS error if I was stepping through the entire sequence. Made me think it might be some timing/race issue, because I first create the workbook, using ‘Copy File’, then attempt to open it with EAS. Maybe there was an insufficient interval between the two (although, as I’ve said, it was not a problem previously) so I experimented with some delays, but that doesn’t seem to make any difference.


#7

Have you tried running the process on a different user account or different machine? I’m not sure what you can do to resolve the problem but that would atleast identify that it’s a possible environment issue. You can also check the Windows Event Viewer (in Service Manager on Windows Server), which might display the errors you are getting in more detail.


#8

Yes, on the different accounts.

What another user here recounted was that he had seen the same thing, or something very similar, when he had briefly played with the tool a few months ago, which had been solved by removing a FoxIt plugin from Excel. I did the same, and it’s been running great ever since (fingers crossed). Why this was not a problem prior to about Wednesday, but was after, is a mystery for the ages.

ddk


#9

I have suffered exactly the same issue here but I think I found the reason. If while you are running the robot an unhandled exception occurs the Excel process remains running. If you open task manager and kill the process then it starts working again.
I had this issue with both Excel and Internet Explorer but this fixed my issue.


#10

I had also definitely seen the orphaned Excel process behavior you’re describing. I actually put together a little PowerShell script with an icon on my desktop to kill those things without having to bother with Task Manager. As I mentioned above, the apparent source of my problem was an Excel plugin (for FoxIt in our case) and the solution was to remove the plugin from Excel. Don’t know how or why it became a problem, when it did not seem to be prior to that date. It shouldn’t be a surprise if other plugins also caused problems.

ddk