Excel Application Scope - pop window issue

Scenario:

  1. Robot will stuck when open excel with a pop window.
  2. And we found a solution that using parallel activity to start a new process to click “Don’t Update” button to close the window to avoid robot stucking.
  3. But the clicking action is not stable, so we want to use “element exists” + “retry” activity to click the “Don’t Update” button to let robot clicking button more stable.

Finally, we found that the robot will stuck again. Please refer below screen for the details.

image

Steps to reproduce:

Refer to below screenshots. And the robot will stuck in “element exists” activity and “Exception application scope” activity. What’s more, no error will be thrown by the Robot!

Current Behavior:

Robot is stuck. And there is no error messages be thrown out!

Expected Behavior:

Robot really follow the parallel stepps to check the button and retry to click the button.
And if any time out reached, robot should throw exception.

Studio/Robot/Orchestrator Version:

Last stable behavior: 2018.2.3
Last stable version: 2018.2.3
OS Version: Win10 Enterprise 64bit
Others if Relevant: (workflow, logs, .net version, service pack, etc):

1 Like

TRY THIS

last activity, click “Dont update” button

Hello,

a pretty annoying problem indeed.
If you’re allowed to, you can permanently solve this problem by going to Options -> Advanced Settings -> In “General” menu, uncheck “Ask to update automatic links”.

Best regards,
Mustafa

Thanks Skini, We tried it before. The robot won’t go to the first activity until excel application scope was processed finished. But the Excel application scope was stuck, and no exception.

Thanks Friend. I think this solution is ok.
But it’s part of our requirement that robot should click the button to avoid it.

I feared that. I just want you to know that I have been facing this issue before, and this pop-up is the most annoying thing I ever met. So far, this is the only solution that works for me :slightly_frowning_face:

This may not be a good idea, because in the same machine you may open many files and you may want this enabled for those files.

Yes but this is a general setting that applies for any Excel file.

We found a work around to solve the problem, which can make opening excel activity very stable.

  1. Use start process activity to start the excel file. App is “EXCEL.EXE” and input argument is to be opened excel file path.
  2. And then check those window exists or not. If yes, then close those windows.
  3. At last, use excel application scope to attach the opened excel file, and output the workbook application.
3 Likes

Use KILL EXCEL before you use Excel Application scope, it will clear all the excel instances then it will open a fresh excel activity , i dont think it will create an issue , please try this and let me know

Regards,
Siva Sankar K

Killing Excel will absolutely not solve this issue. Why would killing the process change the fact that some links require updating upon the opening of a file?
Plus, all other Excel files will be closed if you kill the process …

else other option would be block pop ups in your excel application settings…

Hi - I am having this issue too, but for me it’s not the Update Linked Data message box. There are several message boxes produced automatically by a macro-enabled workbook as soon as the workbook is opened and as soon as UiPath tries to read or interact with the spreadsheet (not trying to execute any macros at this stage). The UiPath workflow becomes locked, and does not timeout. The parallel activities I have set up to click the messages do not fire. I cannot modify the spreadsheet.

Could a UiPath dev please check what has gone wrong with Parallel activities (since 2018.2?) and also why no timeouts occur on Excel activities that become locked?

Thanks!

Hi There is work around for this.

  1. use run to open the file by providing full path of excel to it.
  2. Check on element exist once excel is open.
  3. If it exists then click on don’t update.
  4. Once all set use excel application scope activity to perform next process.
    This is working fine for me under all circumstances without fail, please try it out.
1 Like

Hi @GirishKharabe, unfortunately this doesn’t solve my problem. That will solve the start-up dialog messages to do with updating links and yes it will help with the start-up macro message boxes, but, as mentioned above, the message boxes I am encountering are raised by macros embedded in the file that are also triggered upon sheet change or selection change and so pop up when doing UiPath activities such as “Get worksheets” and “Read range” and when trying to exit the Excel Application Scope. In these cases, UiPath has no timeout and will wait for the activity to finish indefinitely, and it also seems to be blocking any parallel activities. Once you trigger this activity (e.g. Read range) there’s no way to have UiPath find and click the dialog box that appears. According to OP, Parallel used to work in these situations but at some point after 2018.2.3 it stopped working.

1 Like

I was able to test out my workflow on 2018.2.3 with a rolled-back Excel Activities package, and it still does not execute as one would expect - the Excel Application Scope becomes stuck as soon as the execution enters it, and never times out, and never cedes time or control to the other parallel activities. Is there a way to force it to timeout, so we can handle the dialog boxes in a try-catch or something?

Edit: Success! Extracting each of the different dialog box monitoring/clicking branches in the Parallel collection as separate workflows (i.e. replacing each sequence with Invoke Workflow activities) and ticking the “Isolated” checkbox on each allows it to work as expected. At least one of the sequences/workflows should be left as not isolated (synchronous) so that the rest of the rest of the workflow waits for the Parallel process to complete, in my case I left the sequence containing the Excel Application Scope alone - though you could achieve this using some other variable or file-based signalling, or just a fixed delay. I see that the parallel branches are started left-to-right, so the Excel Application Scope synchronous workflow/sequence has to be the right-most branch in order to not block the whole workflow thread before the other threads are started asynchronously.

4 Likes

hi
try “Dont update” button click activity property ==> continue on error as “True”

1 Like

me also i have the same issue

what the solution for this

i am also having this issue, if anyone solved this before, please help for the correct solution ? i am in stuck :confused:

Thanks … This one works like charm. Such a painful problem to solve it was, though seems easy.

1 Like