Excel Application Scope not able to open Excel file

I have used Excel Application scope activity in my RE-Framework template. in that activity BOT need to read the config file and Input Template, but it is not working. kindly help

Are you using Read Range application? Kindly elaborate your problem

Yes in that I have used Read range activity.
Problem is after BOT started BOT need to read the excel file with read range activity and for that i have used Excel application scope activity, but BOT unable to read the excel file for path i have mentioned.

Make sure that the SheetName property in Read Range activity matches with the sheet name in the excel file.

@nilesh.mahajan What is the Error that you get ?

No error, no exception but at that stage BOT has not move ahead, no termination also happened. Ideal BOT

@nilesh.mahajan Are you Debugging or Executing the Workflow ?

I have tried with Execution as well as Debug both, but same result no response from bot

@nilesh.mahajan Have you checked the Output of the Read Item Code using a Message Box ?

Hi @nilesh.mahajan,

Please check whether the given sheet name exists and the file path you have given is correct.
If the same problem repeat use ‘Kill Process’ activity and pass ‘excel’ in the ‘Process name’ property before the excel application scope.


BOT is not reading the excel so it will not show anything in Message box
Below is the stage where BOT stucked and not move ahead.

@nilesh.mahajan Can you Check if in the Task Manager , Excel Applicaitions are present, if present then kill them and run the process again. If it still doesn’t work then Try using Workbook Activities.