Excel Application Scope: Failed opening the Excel file - Reason

Hello Team,
Can any one please let me know why do we get error - Excel Application Scope: Failed opening the Excel file.

Also i retried the same excel file with making any changes to excel as well as workflow it worked fine,…What may be reason for failure…
Please gudie

Hey @mayur.mandge is the file closed?

Yes,file is closed

Some of the issues could be:

  1. File is corrupt
  2. File is open
  3. File is not accessible
  4. File path is too long

Please post the error message so that we can try narrow it down

Actually i’m triggering the process from orchestrator every 10 mins to read excel file from a location and process it…

Ok,But when i tried for the same file it worked fine

So im looking for exact error that was cause this error


Is it .xls or .xlsx ?

If it is .xlsx then try to use Read Range activity and check


it is .xlsx, but how it failed for the first time and was processed successfully for second time
any idea


There are many cases we need to take a look, we can’t specify that, maybe the file is not ready for reading / some other resources are blocking

Hope this may helps


1 Like

Hi @mayur.mandge,
are you certain that ‘robot’ can access that folder, what I mean does the robot has sufficient rights on that folder?
If robot is using the same username as you are using and you have access than it should be enough, if that is the case then it is used by other process or user.
In this process do you download excel file from web page? Maybe file which you are accessing is not downloaded and that’s why it is corrupted?

For Excel Application Scope do check if MS office is installed on target machine.
To check file Access you can first verify if File.Exist

Yes, the robot has rights to access folder and the excel file is being placed manually in respective folder