Errors when debugging

Hi all,

I created a RPA in 2022 working mainly with SAP, and it was working perfectly until a few weeks ago. Now, when I debug this RPA or run it, I have a lot of UI-REL-001 and UI-DBP-006 errors appearing. It feels like these errors are mainly due to Type Into and Click activities related to SAP. When I “Run from” an activity, it works but it I want to Debug File or Run File I have a lot of errors like.

I have tried a few things to fix the issue but it didn’t work:

  • Put the activities related to SAP into an Open Application activity
  • I have changed the “Edit selector” and “Indicate on screen” of each activity that had a error

Would you be able to help me on that?

Here is a screenshot of the errors I get


Have you tried using breakpoint when debugging or running the file


hi @BUISSON_Chloe

Welcome to the community!

So these errors that you’re seeing right now are due to the setup of Workflow Analyzer,
These rules were set to raise error from the governance,

If you want to resolve these you would have to go to each individual activity one after the other from the error list,
You need not change the whole selector, you would just have to use an open application/attach application activity, and place your activity inside it, then you would have to edit the selector and remove the duplicate part from the container activity.

Your Parent Selector/Container should be like this:


and individual activity selector should be like:


and shouldn’t look something like this:


Happy Automation

Hi @adiijaiin, thanks a lot for the explanations!

I went into the workflow analyzer settings and I changed the default actions from Errors to Warnings, could that be an option? Or it is not a correct way of doing?

Also, I tried to do what you said but I don’t understand what you mean by “” in individual and parent selector. Here is what I have in my current selector:

Isn’t it correct? Where should I make the changes you suggested?


Surely it should be the correct thing, these rules are just for putting a standard to the code development that you’re doing, so it should be set to warning.

Secondly I cannot see your selectors, if you put any.


Sorry about that @adiijaiin! Here is an example of one of my selectors:


What you are suggesting is to put this selector into an “Open Application” Activities rather than in the “Type Into” Activity? Could you show me what you mean by “” in the parent and individual selector?

What that error was suggesting is:
the second line in this screenshot shouldn’t be a part of activity.

The rule is about reminding on the concept of defining the top selector (Parent selector) in a container (Open Application, Use…) and then inherit/use it later e.g. for a click. So we can centralize it.

From you screenshot we can see within the top grey highlight the parent selector is inherited and used.

Whenever the top selector (Parent selector) is gray highligted then just delete the first top line and remove its overwriting

I have managed to remove the selector in Grey which, if I understand correctly, is the parent selector.

Is that what you were suggesting? Should that remove the container errors?


Yes if you run the Analyze Project now, there should be one less warning.

More over it should be like that parent window selector should be configured in attach application (container activity)


just let us rephrase it. Use the defined parent selector from container. Remove parent selector from nested activities when it is overwriting the container parent selector and it is the same selector

Hi @adiijaiin and @ppr,

I have tried to change the selector on all the activities that are inside the Open Application as you explained. First, I checked my parent selector inside the Open Application and the selector seems fine (it is the same as the one highlighted in yellow in the screenshot attached). Then I went in each of my Activities selectors that are inside the Open Application to get rid of the parent selector, but even if the selection seems fine to me (parent selector not showing), when I come back to the activity a couple of minutes later, the parent selector is back.

Would you happen to know what I am doing wrong? It feels like I cannot get rid of parent selector in the Children Activities.

Is Open Application the right Activity to use?

See screenchot attached.