Error while using "Create Form Task"

I am trying to implement the new features “Create Form Task” and “Wait for Form Task and Resume”. But I am getting the following error while the process tries to create a new task in Orchestrator.

Operation returned an invalid status code 'OK'

RemoteException wrapping UiPath.Orchestrator.Service.OrchestratorException: Operation returned 
an invalid status code 'OK'
at UiPath.Persistence.Activities.BaseOrchestratorClientAsyncActivity.ThrowIfNeeded(Task task, 
Boolean suppressThrowException)
at UiPath.Persistence.Activities.BaseOrchestratorClientAsyncActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result) at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution (AsyncCodeActivityContext context, IAsyncResult result) at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute (ActivityExecutor executor, BookmarkManager bookmarkManager)

Not sure if this is due to my code or something related to UiPath itself.

I am using Cloud Orchestrator and Studio version 2019.10.0-beta.52

Im facing the same issue, please let me know if anybody has found the solution for the problem

I saw some updates in UiPath.Persistence.Activities today and was hopeful that it will fix the errors. But unfortunately it didn’t work and I continue to get the same error.

1 Like

Please make sure that an Unattended Robot runs the process.

1 Like

@AlinaCapota
Thanks for the response. I converted my Studio bot to unattended and tried again but keep getting the same error.
Also, received few more updates to the Persistence.Activities and UiPath.FormActivities packages. But no luck.

Have you tried publishing the process and running it from the Orchestrator with the Unattended Bot as well? Please make sure that the version of Studio is 19.8 or above and the version of Orchestrator is 19.9 or above (Feature flag ‘Tasks’ enabled per tenant)

Yup. That’s preciously what I did.

My Studio version: 2019.10.0-beta.52
Orchestrator version: 2019.9.262 (Cloud) with Tasks enabled for the service.

How did you solve it?

This is still not solved. I keep updating the packages every second day hoping the issue will get fixed but no luck yet.

Thank you,
Same error for me :frowning:

Hi all, make sure you’re using the full path URL in your Orchestrator connection settings within the robot tray.

It should look something like https://platform.uipath.com/servicename/tenantname/.

2 Likes

@jared - Fantastic. Atleast the things moved forward with your solution. I am still getting an error but will look into it. And at the same time I can also see a task got created in Orchestrator as expected.

I will continue exploring further and post the result here in couple of days.

Thanks for the help.

2 Likes

@adityamooley
I am also facing the same error. Did you find the solution ?

@MinalGupta
The error I mentioned in my initial post got resolved after following suggestion given here - Error while using "Create Form Task"

I can now see a task getting created in Orchestrator but at the same time process is failing due to following error. I am yet to look into it and resolve.

Type ‘System.Collections.IEnumerable’ cannot be serialized. Consider marking it with the DataContractAttribute attribute, and marking all of its members you want serialized with the DataMemberAttribute attribute. If the type is a collection, consider marking it with the CollectionDataContractAttribute. See the Microsoft .NET Framework documentation for other supported types.

Also, make sure you run the process only through Orchestrator since it has to create the task.

Hope this helps.

1 Like

Its resolved. Thanks for replying here