Error When Installing UI Path


#1

Installer(.exe or .msi): .exe

License type(Free, Trial/License code): Free

Studio/Robot version: 2018.1.2

Current behavior: Upon first installing it throws an error. Files appear in appdata but they do not function. A notification comes up that there is an unexpected error please contact support, but I am on CE not enterprise. The robot appears running in task manager but studio fails to open.

Screenshot:

I have attempted to attach the log in pdf form as the .txt/.log version wasn’t allowed…and now I find that new users can’t upload attachments. EDIT: Now that I have the ability, the log is attached.
UIPath_Squirrel_Log.pdf (95.9 KB)

Here is two parts of the log which I think identify the problem. I have tried various solutions mentioned on the web (disable antivirus, clear temp, even redownloaded the installer(.

2017-01-15 16:53:57> Program: Starting Squirrel Updater: --install .

2017-01-15 16:53:57> Program: Starting install, writing to C:\Users\John\AppData\Local\SquirrelTemp
2017-01-15 16:53:57> Program: About to install to: C:\Users\John\AppData\Local\atom
2017-01-15 16:53:57> CheckForUpdateImpl: Couldn’t write out staging user ID, this user probably shouldn’t get beta anything: System.IO.DirectoryNotFoundException: Could not find a part of the path ‘C:\Users\John\AppData\Local\atom\packages.betaId’.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

…(so on so fortha and:)

at Squirrel.UpdateManager.CheckForUpdateImpl.getOrCreateStagedUserId()
2017-01-15 16:53:57> CheckForUpdateImpl: Failed to load local releases, starting from scratch: System.IO.DirectoryNotFoundException: Could not find a part of the path ‘C:\Users\John\AppData\Local\atom\packages\RELEASES’.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

AND

2017-01-15 16:54:31> ApplyReleasesImpl: Couldn’t run Squirrel hook, continuing: C:\Users\John\AppData\Local\atom\app-1.13.0\atom.exe: System.OperationCanceledException: The operation was canceled.
at System.Threading.CancellationToken.ThrowOperationCanceledException()

I was really looking forward to learning this software and getting the diploma through the academy. But I am a little stuck right at the start. Any help would be very appreciated.


Installation issue of UiPath community edition
#2

Hi @John_Davidson,

Refer this post,

Regards,
Arivu


#3

Hey @John_Davidson. Not sure what your permissions are on your workstation but where I work we block apps running outside of Program Files or PF (x86) by Group Policy except for local admin. It will initially install but prevents the CE edition from running because it’s installed in AppData.

Just wanted to throw that out there in case it helps you or someone else.

Regards,
Troy


#4

Thanks, Arivu. I did see that post but unfortunately, none of the fixes mentioned worked. I do not have McAfee but I did disable Norton. I cleared out local data and I ran the installation with admin privileges. All to no avail :frowning: .
Perhaps though I should have replied to that thread rather than creating a new one, but it seemed no more information was forthcoming for those who didn’t have a fix.


#5

Thanks Troy.

I am actually running the program with Administrator rights on a personal PC. But hopefully your advice will help someone else coming across the issue.

Cheers.


#6

Can I bump this! I still really want to use UI path and none of the present solutions have worked. The majority of my UI path study is occurring at home and it is my personal PC that I can’t get it to run on.

“Help me Robo Pro Auto you’re my only hope!” - Or so said someone or other.