Error when initializing the Python module

Hi all,

I am trying out the Python Activities Package in Uipath and have implemented the short example from the UiPath documentation. It works out fine when I execute it on my lapton. However, when I start it from the Orchestrator in another VDI it shows me the error: “Error when initializing the Python module”.

I have tried executing the script from the command line within the VDI and it works out fine. So I suppose there is nothing wrong with the Python Installation on the VDI.

Anyone experienced the same thing and has a solution for it?

I have Python 3.9 installed on both systems.


Welcome to forums

Check if the both python environments are same

like any modules are missing in the VDI environment

Hope this will help you


Hi @Vjola_Cl

Welcome to UiPath community

please check if below parameters are correct:

in Python Scope

  • path of pyton.exe is correct, in vdi if it is installed for one user path might change
  • target - if it is 32 or 64 bit architecture – python installed and the target need to be same
  • and version if it is any thing other than auto

hope this helps

Hi together,

thanks for the quick responses :slight_smile:

The 2nd suggestion from @AdityaVN actually worked out. Apparently the target was the problem.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.