Error using Select Multiple Items Activity

activities

#1

Hi.

I’m recording a job with iExplorer and I facing an Issue when I use the “Select Multiple Items” Activity.

I selected 4 options from a list with Ctrl and then I selected the list with the “Select Multiple Items” Activity. This generates an Array with the 4 elements chosen in the MultipleItems property, so it looks like it’s working fine.

But when I run the job, Uipath returns me this Error:
image

Can someone helps me?

Many thanks in advance.


#2

Hi @alvaro.gomez,

Could you post your page for testing?

Regards,
Hoang Anh.


#3

Hi @anhth15.

Many thanks for your help, but I cannot post it because the page is only available in my client domain.

So, in one hand, I cannot publish any information from my client due to policy restrictions and in the other hand a User and Password is required to access to the page, so it is impossible to access from outside the domain. :slightly_frowning_face:

I’m sorry, but many thanks again for your fast response.

Kind regards.


#4

Hi @alvaro.gomez,

I got it because I’m in the same situation.
I would like to propose another solution for you that is:
Using java script codes to select multiple items in your item list like below link:
https://stackoverflow.com/questions/1295950/javascript-to-select-multiple-options
Hope this help.

Regards,
Hoang Anh.


#5

Hey @alvaro.gomez ,

.net framework version ?
Try with Microsoft .Net Framework 4.5.1 Multi- Targeting Pack .


#6

Hi.

@ddpadil I have .Net 4.7 and the Multi-Targeting Pack installed.
image

@anhth15, I never have worked with javascript but I undesrtand the code.
However I’m a rookie with UiPath and I don’t know how to combine Javascript with UiPath. Is it possible?

Many thanks both for your help.

Kind regards.


#7

Hi @alvaro.gomez,

yeah, UiPath provides a very powerful activity that is “Inject Js Script” which helps you to write java script codes.
Could you post the HTML codes of your combobox control? Maybe someone will help you to write that codes.:wink:

Regards,
Hoang Anh.


#8

How did you overcome this issue? Could you please share your solution ?


#9

Hi.

I have not been not able to solve this issue. The “Select Multiple Items” doesn’t work. At least for me. :sweat:

I had to change the logic of the program using a single Select.

Regadrs.


#10

hello alvaro.gomez, can you try with this simple html and see if its working?
also, can you provide us with the exact version of studio?
https://www.w3schools.com/tags/tryit.asp?filename=tryhtml_select_multiple


#11

Gabriel -

For w3schools it will work correctly. I personally tested it.

Please see my post here with similar issue


#12

@aksh1yadav @badita

Can you please advise something on this issue ?


#13

for me also same issue