Error "Read Range Illegal characters in path" only when using the path through "Get Asset" activity

So as the title says, when i use a “Read Range activity” with a path assigned to a variable it works perfectly but when i assign the path to the variable through the “Get Asset” activity i get the error "Read Range: Illegal characters in path.
I have used a write line to check the path when i obtain it from the “Get Asset” and is exactly as when i type it directly into the variable.

Edit: Added image

Hello @Alvaro_Rivas

Can you please put both the values in a notepad and check the number of characters. I hope there can be some unwanted space or character is there in the file path provided.

So better to write the value to a text file and validate it.


I have tried that and copied the path directly from the variable where it works but it gives the same error

Edit: I could make a video if that helps

Can you do one thing. Copy paste the file to the project folder and try to open from there.

Or move the file to some other folder and cross check once.

The file is inside the project folder, i tried moving it to another folder and it still happens.
Here i recorded the case: UiPath Error - YouTube

Sorry…not able to play the video.
Can you share a screenshot of the activity and the path which you have provided?

I found the problem, it was something so simple.
It was the inverted commas, i deleted them and it works just fine.
Thanks for your time and sorry to bother :sweat_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.