Cannot able to read Orchestrator Asset Value in Read Range

Hi All,

Can Anyone help me out with this. Thanks in Advance

I created Asset Value of Type “Text” (in which give the path file) in Orchestrator
And read the config File REFrame Work and concactinated the states.xlsx file
in read range like this

** In Read Range**
** Config(“assetValue”).ToString+""+“satates.xlsx”**

it s giving me error.

Hi @saritha

My understanding is, "\" is causing this error. Try using "\\" instead.
Do let me know if this worked


Instead you can try Path.Combine(Config("ExcelPath").ToString(),"StatesAndCapitals.xlsx")

Thank u for your reply. I tried , but didn’t work.

Thank u for your reply. I tried , but didn’t work .

Hey @saritha ,
Try use expression Config(“excelPath”).ToString+""+"StatesandCapitals.xlsx to the ‘write line’ activity and check the result. If you don’t find any illegal characters try type to the ‘read range’ activity path without using variables.
If ‘read range’ activity will work you have to compare both string character by character.

However, my guess is that you used quotes in the path. in the config file. Try remove it.


Hi @saritha ,

Small suggestion from my side dont keep double quotes for file path while entering in your asset. There might be chance it is pulling file path with double quotes and it treating as illegal character in path.

You could save your file path in config excel instead of orchestrator asset. Please try above ans let us know. Thanks.

Thanks for ur reply

I did that to and checked the path. Its printing the path exactly.

But not able to read the path in Read Range …

Don’t know exactly where was the mistake…

Please help me with this.

Hi Thanks for ur reply,

I tried using it in config file. It was working

But the thing is , I want it from Orchestrator…

how are you call the asset from orchestrator, hope you are using get asset activity

Hey @saritha
So you are use double quotes. You don’t need it in the path :slight_smile:
Instead: “c:\folder\fileName.xlsx” please use: c:\folder\fileName.xlsx


Hi , gave it in config file
Thank you.

Hi , as u said I changed the quotes which I have given in Orchestrator . Now its working …

Thanks a lot.

Than you everyone for all ur replies…

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.