Error opening workbook. Make sure Excel is installed, any idea?

Anybody facing this issue with 32 bit Excel version?


Source: Excel Application Scope

Message: Error opening workbook. Make sure Excel is installed.

Exception Type: System.Exception

RemoteException wrapping System.Exception: Error opening workbook. Make sure Excel is installed. —> RemoteException wrapping System.IO.DirectoryNotFoundException: Retrieving the COM class factory for component with CLSID {00024500-0000-0000-C000-000000000046} failed due to the following error: 80070003 The system cannot find the path specified. (Exception from HRESULT: 0x80070003).
at System.Runtime.Remoting.RemotingServices.AllocateUninitializedObject(RuntimeType objectType)
at System.Runtime.Remoting.Activation.ActivationServices.CreateInstance(RuntimeType serverType)
at System.Runtime.Remoting.Activation.ActivationServices.IsCurrentContextOK(RuntimeType serverType, Object props, Boolean bNewObj)
at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck)
at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)
at System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)
at System.Activator.CreateInstance(Type type, Boolean nonPublic)
at System.Activator.CreateInstance(Type type)
at UiPath.Excel.WorkbookApplication.StartNewApplication()
— End of inner exception stack trace —
at UiPath.Excel.WorkbookApplication.StartNewApplication()
at UiPath.Excel.WorkbookApplication.InitializeExcelApp()
at UiPath.Excel.Activities.ExcelApplicationScope.<>c.<.ctor>b__48_0(WorkbookArguments args)
at UiPath.Excel.Activities.ExcelApplicationScope.Execute(NativeActivityContext context)
at System.Activities.NativeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

1 Like


Please check below thread and follow the steps.

Error opening workbook. Make sure Excel is installed - #12 by delf


Still not working, have tried all.

1 Like

These are few approaches provided by UiPath team:

Approach 1 : It seems to be registry on that machine was damaged and is missing a key.

try the below steps:

  • Open regedit
    Go To HKEY_CLASSES_ROOT\Typelib{000‌ 20813-0000-0000-C000‌ -000000000046} . Delete the available node. probably 1.7 for office 2013
    Note: {000‌ 20813-0000-0000-C000‌ -000000000046} value changes with IID (in this case 208D5). You might need to refer google to verify the value.

Please refer to the below forum articles

Approach 2:
This issue usually occurs when OS is unable to find the required dll’s.

We recommend you to repair the Microsoft Office 2013
• Right-click the Start button (lower-left corner), and select Apps and Features on the pop-up menu.
• Select the Microsoft Office product you want to repair, and select Modify.
• Depending if your copy of Office is Click-to-run or MSI-based install, do the following.
How would you like to repair your Office Programs , select Online Repair to make sure everything gets fixed, and then select Repair (The faster Quick Repair option is also available, but it only detects and then replaces corrupted files.)
In Change your installation , select Repair and then click Continue.
• Follow the instructions on the screen to complete the repair.

Approach 3# :
Modify a registry key named LoadBehavior. It needs to have its value changed from 3 to 9. It can be found in the following locations:

For 32-Bit Version of Windows

Kindly reboot after making the changes.
Thereafter confirm if you face same issue again.

Approach 4# : (If still the issue persist, please modify the workflow to avoid the issue )

Update the developed workflow. Code workaround would be , open excel application prior to invoking it.
This solution approach has worked for few of our client. ( Important )

Also, further suggestion’s

  1. If feasible change the Excel activities to use Workbook activities which do not need Excel to be installed
    Note: Make sure if you have not used Macros in the excel.
  2. As the issue is intermittent, please use retry scope to handle this error to retry the transaction when the failure happens.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.