Excel application scope : Error openning workbook. Make sure Excel is installed

I could fix it. :wink:
A repair installation of office did it.
Don’t use the quick repair!

1 Like

I got the same problem, what is the real solution for this issue?

don’t rely on the excel app integration.

But If the source is excel file? Don’t you think it must be done using excel app integration?
For example if we want to automate pivot activity in excel.

I’m getting this error as well. It needs to be fixed.

To use Excel Application scope , Excel should be installed on your system because it uses MICROSOFT.OFFICE.INTEROP.EXCEL.DLL in the background for excel operations.

You can use Workbook Activities for such cases. :slight_smile: and the only thing you have to make sure at the time of robot run that Excel should be close or should not run in the background already.

Regards…!!
Aksh

2 Likes

I encountered the same error running Windows 7 64-bit and 2016 Office 365 Business 32-bit. I tried a quick repair and a full repair of Office, but neither solved the problem. Eventually a full uninstall/reinstall of Office 365 did the trick and the error is no longer present. I also ran CCleaner (Registry Cleaner option) between uninstall/reinstall to remove any lingering registry issues.

Some helpful research that others might find useful in diagnosing their own environment (based on registry fixes using regedit.exe or similar):

Although this article is in an answer to Microsoft Word the top answer describes why most people encounter the problem and what to look for in the registry to fix manually. c# - Error accessing COM components - Stack Overflow

The last question in the article above cites a similar problem with a missing folder rather than an empty extra folder in the registry and a link to their fix: c# - Outlook Com not registered - Stack Overflow

In terms of where to look in the registry, I also found this article helpful. In particular if you’re running a similar environment to me with 32-bit Office/Excel on a 64-bit computer, you’ll have a HKEY_LOCAL_MACHINE\SOFTWARE\Classes\WOW6432Node\Interface\ registry route to follow in addition to the HKEY_CLASSES_ROOT\Interface\ described in the other articles.
https://www.fieldstonsoftware.com/support/support_gsyncit_8002801D.shtml
Although the article is written about Outlook, the same logic applies for the Excel error.

Always a good idea to backup your registry beforehand if you decide to do any manual fixes to it!

I encountered the “Excel not installed” error after upgrading to Office 2016 under 64-bit Win 10 Pro. I tried the quick repair, but it didn’t solve the error. I uninstalled Office and reinstalled it. After I reinstalled Office 2016 - it worked. If you’re having issues with Office 2016, try to reinstall it.

1 Like

Hello, I´m having a same problem.

“Excel not installed”

Even after reinstallation of Offices. Also Workbook Activities works (thank you @aksh1yadav) but is there any other solution for Excel Application Scope?

Thanks in advance

br
Jakub

2 Likes

Hey @jakubvanhara

This activity can only be used if the Microsoft Excel application is installed on your machine.
Because the Excel application scope activity uses “Microsoft.Office.Interop.Excel.dll”.

You need to have Microsoft Excel installed in order to have access to the Introp libraries.

To use the features of a Microsoft Office application, we need to use the primary interop assembly (PIA) for the application. The primary interop assembly enables managed code to interact with a Microsoft Office application’s COM-based object model.
To apply PIA that can obtain the reference to interop with excel in your program, you have to install Excel.

Regards…!!
Aksh

Hello and thank you! I have forgotten to mention that I used ReInstall so Excel (and entire Office package) is on my pc (and was before, as well)

br
Jakub

Your Office Version?

1 Like

MS Office 365 ProPlus
Version: 1705

Hi, I am working on a sequence which includes an Excel application scope to launch excel. I get a “sequence has thrown an exception” error “Error opening workbook. Make sure Excel is installed”.

I do have Excel installed (2010) , and I have defined the workbook path in the scope.

I checked the packages and Uipath.Excel.Activities is installed.
The file I want to open is an xlsm file
Any ideas?

Hello,
Always no solution to this issue ?
Excel is correctly installed but we get alternatively “The remote procedure call failed. (Exception from HRESULT: 0x800706BE)” or “Error opening workbook. Make sure Excel is installed”
We need a real solution to this issue.
Thanks

2 Likes

Try to repair the Microsoft Office 2016

• Right-click the Start button (lower-left corner), and select Apps and Features on the pop-up menu.
• Select the Microsoft Office product you want to repair, and select Modify.
• Depending if your copy of Office is Click-to-run or MSI-based install, do the following.
Click-to-run
In How would you like to repair your Office Programs, select Online Repair to make sure everything gets fixed, and then select Repair. (The faster Quick Repair option is also available, but it only detects and then replaces corrupted files.)
MSI-based
In Change your installation, select Repair and then click Continue.
• Follow the instructions on the screen to complete the repair.

2 Likes

I had the same issue, try to complete uninstall MS office and UiPath.
Then install the MS office again and then uipath. It should work.

2 Likes

@Strajk
Yes, it helped with this kind of issue!
Also, make sure you are running all as administrator

Thanks. Your comments helped me to solve my problem.

This worked for me. Thank You!