Error on activity "Kill Process"

activities

#1

We want to use Kill Process to terminate Internet Explore. This one works fine on single Desktop, but failed on server where multiple developers are working in concurrent mode.

Our case is a bit special one.

We had deployed a development environment as below:

  • Windows server 2016
  • Multiple developers login at the same time, with different username/password
  • Multiple developers are developing robots at the same time, may be some of them opening IE.

When we launch a very simple workflow with Kill Process, it performed as below:

  • Success with killing all “iexplore” process of current user
  • It also throws exception:
    System.ComponentModel.Win32Exception

Please refer to attached images for more detail.


Access Denied Error message while using 'Kill Process' activity
#2

Hi @datnt,

Please update you Dotnet framework in your machine and try again.

	Supported Versions
Operating System
Windows 7 update KB 2533623
Window 7 N update KB 968211
Windows 7 SP1 Update for Universal C Runtime
Windows 8.1
Windows 8.1 N Media Feature Pack KB 2835517
Windows 10
Windows 10 N Media Feature Pack KB4039813
Windows Server 2008 R2 update KB 963697 and the Desktop Experience feature
Windows Server 2012 R2
Please note that Windows Server 2012 R2 Standard and Datacenter require the Essential experience role and Essentials Media Pack. For more information, see the following link.
Windows Server 2016
Citrix environments (!)

.NET Framework minimum: 4.5.2

Regards,
Arivu :slight_smile:


#3

In my case problem was “kill process” by mask try to kill process of different user.

I solved this issues by writing my own code and put in “Kill process” process variable. See screenshot.


#4

True If you will try to kill a process ran by other users you will get this prob until and unless you have admin rights :slight_smile:

By using GetProcessesByName you will be able to get the process resources on the local computer so you can kill that :slight_smile:

Regards…!!
Aksh


#5

@arivu96, @Uemoe, @aksh1yadav: Thank you so much for your feedback.

@Uemoe and @aksh1yadav:
We had tried the method you mentioned (i.e: used activity GetProcessesByName), but we received another error message. This time, UiPath does not close any process at all. Please refer to below images for more information.

@arivu96: We are currently use “Windows Server 2016”
According to the link that you provided:
https://studio.uipath.com/docs/software-requirements

Currently our status is as below:

  1. We had not received any message related to “The name of the machine changes every time it is spawned or the user logs in.”

  2. We had not received issue related to “The licensing information is not persistent;”
    Further more, how can we know that we are having problem with “The licensing information is not persistent;”

We are having multiple dotNet framework on our development PC, the highest version is 4.0
Could you please help to confirm that, upgrade to “.NET Framework minimum: 4.5.2” would solve issue of killing process for our case?


#6

Might be but better to go with 4.6 IMHO :slight_smile:

Or check on your local development system what version you are having :slight_smile:

Regards…!!
Aksh


#7

It’s always better have recommended version of framework in place.

But try to use try-catch or just ContinueOnError = True for kill process activity. If you able to kill you only iexplorer process we will know that problem was the just in system rights to do it.

Actually maybe my solution didn’t solve problem of retrieving current user processes.

I remembered I have problem with IE, but I send to you code with acrobat, and for acrobat it less likely to get situation when other user on server is running at same time acrobat.


#8

Hi,

If u keep the kill process in the try catch block then it will not give any error


#9

@Uemoe, @shaik
Thank you for your suggestion.

I want to solve issue at the root cause rather than robot just workable.