Error occurs when running an Orchestration Process/Background Process


We have developed an Orchestration Process, which is actually invoking/starting different jobs in Orchestrator in a specific order. Between these executions there is some folder and file operations in terms of validating and moving files to different locations. The process does not contain any UI activites and we have only been using the packages that comes with the template (Orchestration Process).

When running it attendantly from my own User Session, then there is no issues. But when I run it as background process from Orchestrator, then it gets an error. It executes in Session 0 as NT Authority/Local Service.
The error occurs when trying to read the Config-file in the initialization sequence.
Errormessage: “Read range (Settings and Constants sheets): The workbook does not exist”

I assume that when running it in Session 0, then there is some folder permission/accesses that is not defined. But that is only my assumption.

I have also changed the UiPath Service to run as a specific user which has access to the folder/files, but the executor won’t start. The errormessage: RemoteException wrapping System.Exception: Could not start executor.

Thanks in advance!

1 Like

For this check whether the filepath is correct or not

And for this

For more details on trouble shoot

Cheers @srvany

Hi Palaniyappan,

Thanks for you reply.
The filepath is correct. When I run it attendantly, then the process is succesfully executed.
Do I need to configure anything on the robot/machine?

Hi, srvany,
How did you resolved this?


Hi thanu.thomas,

First of all running Background Processes won’t allow you to use any UI Activities, which includes Excel. So first of all make sure, that your process don’t contains any of these activites otherwise it will have unexpected behaviours.

We are using the Background Process in Session 0 as an orchestrator. So before and in between every “Foreground executions”, the robot in Session 0 will check and validate if files exist and move them to a specific folder. Once that is approved, the Background Process will start a job.

The thing we were doing wrong was that we only had one robot connected to our Orchestrator, so our robot were running in both session 0 and session 1.
You need to have two robots connected to the orchestrator. So one of them is running in background and the other executes the processes in the foreground. And both of them has the same permissions.

1 Like