Error in Uipath Assistant for choosing connections - Integration Services

Hi all,
I need help with an error a user got while trying to run a bot.

This bot uses a Salesforce connector with Integration Service. I set up this bot in the orchestrator and allow the user to pick for a specific connection.

In my case, I didn’t have this problem but other users do.
Does anyone have any idea what I need to do to fix this problem?


Can you check the connection available in the folder.


Is the connection valid?

while creating process can you show the screenshot what you have done in the dropdown for connection


Hi @Mohan_Reddy
Here is a screenshot of the connection available in My Workspace folder.

I have two more connectors in the Shared folder, but i cannot see any of these ones in the Assistant.

Hi @Anil_G
Do you mean while creating process in the Orchestrator?
Here is a screenshot of how i did it. Just let the default option to let users to choose the connector.

I also tried to select one connector as default but it didn’t work.

I can give you more details about this bot.

  • Package installed: UiPath.Salesforce.IntegrationService.Activities 6.1.0
  • Project settings: Windows compatibility. (not Windows-Legacy)
  • An example of one of the activities i used (2nd screenshot)


If you configure the user in the orchestrator and select it while creating it should work…can you try the same…

If you keep default in process directly in studio then the user might need access to it and generally those get created in personal workspace


I have tried changing the user in both Orchestrator and Studio but i got the same error.
It’s strange because one of my colleagues says it works but another ones say they get this error.

I am not sure if there is something else I need to check, like licenses, permissions, system requirements…


Please check the roles given to both users in orchestrator


Ok I had a meeting with someone of UiPath support and the error was due to a old version of UiPath Assistant.

Since i was working with a 2023 version library and I had installed UiPath assistant v2022, then it dropped that error.

Once I updated the Assistant, the error is not longer visible.
I hope this answer helps someone with a similar problem.
Thanks all for your help.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.